summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Nicholson <mikempls@users.noreply.github.com>2019-07-23 15:19:29 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 13:44:06 +0300
commitd2821368e0b593b201c77b46f3e5461ffcedd4f8 (patch)
tree79024111ec5d078dacc5df3d0ba22f7116b057bf
parentf23828890d9ff9a1e02266faa87179447652c9dc (diff)
downloadmeta-mlinux-atmel-d2821368e0b593b201c77b46f3e5461ffcedd4f8.tar.gz
meta-mlinux-atmel-d2821368e0b593b201c77b46f3e5461ffcedd4f8.tar.bz2
meta-mlinux-atmel-d2821368e0b593b201c77b46f3e5461ffcedd4f8.zip
Update support for mulitarch base image
-rw-r--r--recipes-core/images/mlinux-factory-image.bb4
-rw-r--r--recipes-core/images/mlinux-minimal-image.bb4
2 files changed, 5 insertions, 3 deletions
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 258fe44..9955f71 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -26,8 +26,8 @@ IMAGE_INSTALL += "autossh"
IMAGE_INSTALL += "monit"
# LoRa support (MTAC-LORA accessory card)
-IMAGE_INSTALL += "lora-gateway-utils lora-query lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation"
-IMAGE_INSTALL_mtbsp-at91 += "lora-network-server mtac-xdot-util"
+IMAGE_INSTALL += "lora-gateway-utils lora-query lora-network-server lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation"
+IMAGE_INSTALL_mtbsp-at91 += "mtac-xdot-util"
# MQTT server
#IMAGE_INSTALL += "mosquitto"
diff --git a/recipes-core/images/mlinux-minimal-image.bb b/recipes-core/images/mlinux-minimal-image.bb
index 78ffcf3..2cecc1e 100644
--- a/recipes-core/images/mlinux-minimal-image.bb
+++ b/recipes-core/images/mlinux-minimal-image.bb
@@ -12,7 +12,7 @@ CORE_FEATURES = "packagegroup-core-boot packagegroup-distro-base \
packagegroup-base-usbhost packagegroup-base-usbgadget \
udev-extraconf usb-gadget-mode \
sysfsutils module-init-tools \
- bash procps mtd-utils mtd-utils-jffs2 \
+ bash procps \
openssh-sftp-server \
util-linux-mount util-linux-umount \
start-stop-daemon \
@@ -23,6 +23,8 @@ CORE_FEATURES = "packagegroup-core-boot packagegroup-distro-base \
get-eeprom-device-config \
"
+CORE_FEATURES_mtbsp-at91 += "mtd-utils mtd-utils-jffs2"
+
NETWORKING_FEATURES = "ppp curl iproute2 \
iptables iputils \
"