summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-01-05 18:28:52 -0600
committerJohn Klug <john.klug@multitech.com>2023-05-24 16:33:24 -0500
commitb4fafa5d814c28173c185280c7ff33905f4d376a (patch)
tree2bcb16944343f10daf7a1e8c37fd5fd1a8249aaa
parent3d05dfdfeca2f8919b3e2f080beb2a73a4410ddf (diff)
downloadmeta-mlinux-atmel-b4fafa5d814c28173c185280c7ff33905f4d376a.tar.gz
meta-mlinux-atmel-b4fafa5d814c28173c185280c7ff33905f4d376a.tar.bz2
meta-mlinux-atmel-b4fafa5d814c28173c185280c7ff33905f4d376a.zip
Properly apportion rs9113 related modules for mtrv1
-rw-r--r--recipes-core/images/mlinux-mtrv1-image.bb6
-rw-r--r--recipes-core/images/mlinux-rs9113-mtrv1-image.bb24
2 files changed, 21 insertions, 9 deletions
diff --git a/recipes-core/images/mlinux-mtrv1-image.bb b/recipes-core/images/mlinux-mtrv1-image.bb
index 19dd8c1..c2316b6 100644
--- a/recipes-core/images/mlinux-mtrv1-image.bb
+++ b/recipes-core/images/mlinux-mtrv1-image.bb
@@ -3,7 +3,6 @@ DESCRIPTION = "mLinux base mtr image"
LICENSE = "MIT"
require mlinux-minimal-image.bb
-MULTITECH_MTAC = ""
CONSOLE = "sysvinit-inittab-start-open"
@@ -42,7 +41,7 @@ WIFI_FEATURES = " \
hostapd-cfg \
"
-BLUETOOTH_FEATURES = ""
+BLUETOOTH_FEATURES = "bluez5 bluez5-pand bluez5-mlinit"
# Add all timezones available
# ntpdate will sync time every 30 min by default via cron
@@ -70,8 +69,7 @@ MULTITECH_FEATURES_append = " \
MISC_FEATURES = "minicom lrzsz nano pps-tools"
# Extra stuff to install
-IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils python3-pygps-pyc"
-IMAGE_INSTALL_append = " uxfp qfirehose"
+IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils"
IMAGE_INSTALL_append = " \
${TEST_FEATURES} \
diff --git a/recipes-core/images/mlinux-rs9113-mtrv1-image.bb b/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
index 91e8d67..43b8e8d 100644
--- a/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
+++ b/recipes-core/images/mlinux-rs9113-mtrv1-image.bb
@@ -25,8 +25,6 @@ NETWORKING_FEATURES_append = " bridge-utils \
openssl \
rsync \
iperf3 \
- ppp-radioresetwait \
- radio-reset-background \
mii-diag \
tcpdump \
netcat \
@@ -43,7 +41,7 @@ WIFI_FEATURES = " \
hostapd-cfg \
"
-BLUETOOTH_FEATURES = "bluez5 bluez5-pand bluez5-mlinit"
+BLUETOOTH_FEATURES = "bluez5 bluez5-pand"
# Add all timezones available
# ntpdate will sync time every 30 min by default via cron
@@ -71,13 +69,29 @@ MULTITECH_FEATURES_append = " \
MISC_FEATURES = "minicom lrzsz nano pps-tools"
# Extra stuff to install
-IMAGE_INSTALL_append = " kernel-module-rs9113 rs9113rf rs9113-util rs9113-utils-extra rs9113-misc rs9113-autostart"
-IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils python3-pygps-pyc"
+
+RSI_91X_FEATURES = " \
+ kernel-module-rsi-91x \
+ kernel-module-rsi-bt91x \
+ kernel-module-rsi-btusb \
+ kernel-module-rsi-usb \
+ kernel-module-rsi-91x-sta-ap \
+ kernel-module-rsi-usb-sta-ap \
+ rs9113-fw \
+ rsi-91x-fw \
+ rsi-91x-utils \
+ wireless-regdb-static \
+ "
+RSI_91X_ADDITIONAL ??= "rsi-91x-autostart"
+
+IMAGE_INSTALL_append = " gpsd gpsd-conf gpsd-gpsctl libgps ntp ntp-utils gpspipe gps-utils"
IMAGE_INSTALL_append = " uxfp qfirehose"
IMAGE_INSTALL_append = " \
${TEST_FEATURES} \
${WIFI_FEATURES} \
+ ${RSI_91X_FEATURES} \
+ ${RSI_91X_ADDITIONAL} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \
${TIME_FEATURES} \