summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-12-15 13:07:24 -0600
committerJohn Klug <john.klug@multitech.com>2023-05-24 16:33:24 -0500
commita622278f5d79923a5a8f8ff7dfe8e362ca0baac2 (patch)
tree694b254f522ebcab79b9c8577a928768ecd3e9b6
parent4feb7d8fd53fc949e3749f1b31f342029929a50f (diff)
downloadmeta-mlinux-atmel-a622278f5d79923a5a8f8ff7dfe8e362ca0baac2.tar.gz
meta-mlinux-atmel-a622278f5d79923a5a8f8ff7dfe8e362ca0baac2.tar.bz2
meta-mlinux-atmel-a622278f5d79923a5a8f8ff7dfe8e362ca0baac2.zip
Add rsi-91x features to the base mLinux image
-rw-r--r--recipes-core/images/mlinux-base-image.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-core/images/mlinux-base-image.bb b/recipes-core/images/mlinux-base-image.bb
index 3bdbd77..d1f7f3c 100644
--- a/recipes-core/images/mlinux-base-image.bb
+++ b/recipes-core/images/mlinux-base-image.bb
@@ -32,6 +32,18 @@ WIFI_FEATURES = " \
hostapd-cfg \
"
+RSI_91X_FEATURES = " \
+ kernel-module-rsi-91x \
+ kernel-module-rsi-bt91x \
+ kernel-module-rsi-btusb \
+ kernel-module-rsi-usb \
+ rs9113-fw \
+ rsi-91x-fw \
+ rsi-91x-utils \
+ wireless-regdb-static \
+ "
+RSI_91X_ADDITIONAL ??= "rsi-91x-autostart"
+
BLUETOOTH_FEATURES = "bluez5"
BLUETOOTH_INIT ??= "bluez5-mlinit"
@@ -66,6 +78,8 @@ DEBUG_FEATURES = ""
IMAGE_INSTALL_append = " \
kernel-modules \
${WIFI_FEATURES} \
+ ${RSI_91X_FEATURES} \
+ ${RSI_91X_ADDITIONAL} \
${BLUETOOTH_FEATURES} \
${BLUETOOTH_INIT} \
${FILESYSTEM_FEATURES} \