summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-03-27 15:26:27 -0500
committerJohn Klug <john.klug@multitech.com>2019-03-27 15:26:27 -0500
commit9311629bccb42dccddf78138ecda7fe65194cf4d (patch)
tree86c84858ad350d72583547895e1af551da2cfe21
parent25101321f985a91d5b5f8e3fc9a72c4e7dc296a0 (diff)
downloadmeta-mlinux-atmel-9311629bccb42dccddf78138ecda7fe65194cf4d.tar.gz
meta-mlinux-atmel-9311629bccb42dccddf78138ecda7fe65194cf4d.tar.bz2
meta-mlinux-atmel-9311629bccb42dccddf78138ecda7fe65194cf4d.zip
Add python-gatt-server example to mLinux
-rw-r--r--recipes-connectivity/bluez/python-gatt-server_1.0.bb24
-rwxr-xr-xscripts/build-feed-extras.sh2
2 files changed, 25 insertions, 1 deletions
diff --git a/recipes-connectivity/bluez/python-gatt-server_1.0.bb b/recipes-connectivity/bluez/python-gatt-server_1.0.bb
new file mode 100644
index 0000000..76069f6
--- /dev/null
+++ b/recipes-connectivity/bluez/python-gatt-server_1.0.bb
@@ -0,0 +1,24 @@
+inherit allarch
+HOMEPAGE = "https://github.com/Jumperr-labs/python-gatt-server"
+SRCREV = "a39ef9773e9ba845f4303b1dfd2efddf24b02238"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c53d04442d1a229d62549856b7ec456a"
+
+SRC_URI = "git://github.com/Jumperr-labs/python-gatt-server.git;protocol=git"
+
+RDEPENDS_${PN} += "python-dbus python-pygobject"
+
+DBTEXEC = "${libexecdir}/bluetooth/"
+DEST = "${D}${DBTEXEC}"
+
+FILES_${PN} = "${DBTEXEC}"
+
+
+do_install_append() {
+ install -d ${DEST}/${PN}
+ install -m 0755 ${S}/*.py ${DEST}/${PN}
+}
diff --git a/scripts/build-feed-extras.sh b/scripts/build-feed-extras.sh
index 8fb9d3f..284c7b4 100755
--- a/scripts/build-feed-extras.sh
+++ b/scripts/build-feed-extras.sh
@@ -4,7 +4,7 @@
FS_PACKAGES="sshfs-fuse fuse-exfat exfat-utils"
NET_PACKAGES="wget netcat ipsec-tools openvpn iftop dnsmasq strongswan stunnel tunctl ethtool openobex obexftp"
UTIL_PACKAGES="logrotate fatrace stressapptest gawk rsyslog zip gnupg rrdtool"
-DEV_PACKAGES="strace mono gdb git vim python-pip python-pyopenssl python-pygobject openjdk-8 node-red strace"
+DEV_PACKAGES="strace mono gdb git vim python-pip python-pyopenssl python-pygobject openjdk-8 node-red strace python-gatt-server"
SUP_PACKAGES="pps-tools setserial boost diffutils"
bitbake linux-firmware $FS_PACKAGES $NET_PACKAGES $UTIL_PACKAGES $DEV_PACKAGES $SUP_PACKAGES