summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-11-08 14:51:31 -0600
committerJohn Klug <john.klug@multitech.com>2023-05-24 16:29:36 -0500
commit7ce8f91bf6c25a921ae9be1948865d05104d6434 (patch)
treef51467f95cbb3b35de22accf2fd6f89be4e05e10
parentf0c1eac02f9c917267a8bb968060762f0de99967 (diff)
downloadmeta-mlinux-atmel-7ce8f91bf6c25a921ae9be1948865d05104d6434.tar.gz
meta-mlinux-atmel-7ce8f91bf6c25a921ae9be1948865d05104d6434.tar.bz2
meta-mlinux-atmel-7ce8f91bf6c25a921ae9be1948865d05104d6434.zip
Fix MTAC-ETH AP2 for hardware versions MTCDT-0.0, 0.1
-rw-r--r--recipes-core/udev/eudev/mtcdt/accessory_ethernet.rules8
-rw-r--r--recipes-core/udev/eudev_%.bbappend2
2 files changed, 8 insertions, 2 deletions
diff --git a/recipes-core/udev/eudev/mtcdt/accessory_ethernet.rules b/recipes-core/udev/eudev/mtcdt/accessory_ethernet.rules
index 64739e0..edc0cc0 100644
--- a/recipes-core/udev/eudev/mtcdt/accessory_ethernet.rules
+++ b/recipes-core/udev/eudev/mtcdt/accessory_ethernet.rules
@@ -15,8 +15,14 @@ SUBSYSTEM!="net", GOTO="mlinux_end"
# Two port hub case:
# Some MTCDTIP-0.1:
ENV{DEVPATH}=="/devices/platform/ahb/700000.ehci/usb1/1-2/1-2.3/1-2.3:1.0/net/eth1", NAME="eth2"
+# AP1 /devices/platform/ahb/700000.ehci/usb1/1-2/1-2.2/1-2.2:1.0/net/eth1
+
# MTCDT-0.0 and MTCDT-0.1:
-ENV{DEVPATH}=="/devices/platform/ahb/700000.ehci/usb1/1-2/1-2.2/1-2.2:1.0/net/eth1", NAME="eth2"
+ENV{DEVPATH}=="/devices/platform/ahb/700000.ehci/usb1/1-2/1-2.1/1-2.1.2/1-2.1.2:1.0/net/eth1", NAME="eth2"
+# AP1 /devices/platform/ahb/700000.ehci/usb1/1-2/1-2.1/1-2.1.1/1-2.1.1:1.0/net/eth1
+
# MTCDT-0.2:
ENV{DEVPATH}=="/devices/platform/ahb/700000.ehci/usb1/1-2/1-2.1/1-2.1.2/1-2.1.2:1.0/net/eth1", NAME="eth2"
+# AP1 /devices/platform/ahb/700000.ehci/usb1/1-2/1-2.1/1-2.1.1/1-2.1.1:1.0/net/eth1
+
LABEL="mlinux_end"
diff --git a/recipes-core/udev/eudev_%.bbappend b/recipes-core/udev/eudev_%.bbappend
index 0602568..a8a608a 100644
--- a/recipes-core/udev/eudev_%.bbappend
+++ b/recipes-core/udev/eudev_%.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PR .= ".mlinux13"
+PR .= ".mlinux14"
SRC_URI_append_mtcdt = " \
file://accessory_ethernet.rules \