summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-09-05 11:33:26 -0500
committerSerhii Kostiuk <serhii.o.kostiuk@globallogic.com>2020-05-20 19:50:20 +0300
commit6e767e79c95b109fc950975c37dbc143e280f3da (patch)
treeb85d71b2823b158218e4ff2fc2fc9b7efec2ffe7
parentea65654f5c64b4f7c7d678425780bdec95962a4f (diff)
downloadmeta-mlinux-atmel-6e767e79c95b109fc950975c37dbc143e280f3da.tar.gz
meta-mlinux-atmel-6e767e79c95b109fc950975c37dbc143e280f3da.tar.bz2
meta-mlinux-atmel-6e767e79c95b109fc950975c37dbc143e280f3da.zip
Remove += from all image recipe files
-rw-r--r--recipes-core/images/mlinux-factory-image.bb57
-rw-r--r--recipes-core/images/mlinux-mono-image.bb2
-rw-r--r--recipes-core/images/mlinux-mtcap-debug-image.bb2
-rw-r--r--recipes-core/images/mlinux-mtcap-image.bb14
-rw-r--r--recipes-core/images/mlinux-mtr-image.bb6
-rw-r--r--recipes-core/images/mlinux-mtrv1-image.bb10
-rw-r--r--recipes-core/images/mlinux-rs9113-base-image.bb2
-rw-r--r--recipes-core/images/mlinux-rs9113-factory-image.bb2
-rw-r--r--recipes-core/images/mlinux-sdk.bb2
-rw-r--r--recipes-core/images/mtcap-modules.inc2
10 files changed, 50 insertions, 49 deletions
diff --git a/recipes-core/images/mlinux-factory-image.bb b/recipes-core/images/mlinux-factory-image.bb
index 68b79fb..3588e20 100644
--- a/recipes-core/images/mlinux-factory-image.bb
+++ b/recipes-core/images/mlinux-factory-image.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "mLinux factory image"
# For now we don't put this in MTR or AEP
# Password restrictions library from Redhat
-IMAGE_INSTALL += "libpwquality"
+IMAGE_INSTALL_append = "libpwquality"
LIGHTTPD = "lighttpd \
lighttpd-module-cgi lighttpd-module-indexfile \
@@ -16,35 +16,34 @@ LIGHTTPD = "lighttpd \
"
# Lighttpd web server
-IMAGE_INSTALL += "${LIGHTTPD}"
+IMAGE_INSTALL_append = "${LIGHTTPD}"
-IMAGE_INSTALL += "sqlite3"
+IMAGE_INSTALL_append = "sqlite3"
-IMAGE_INSTALL += "autossh"
+IMAGE_INSTALL_append= "autossh"
# Monit system/process monitor
-IMAGE_INSTALL += "monit"
+IMAGE_INSTALL_append = "monit"
# LoRa support (MTAC-LORA accessory card)
-IMAGE_INSTALL += "lora-gateway-utils lora-query lora-network-server lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation"
+IMAGE_INSTALL_append = "lora-gateway-utils lora-query lora-network-server lora-packet-forwarder-usb lora-gateway-geolocation-utils lora-packet-forwarder-geolocation"
IMAGE_INSTALL_mtbsp-at91_append = "mtac-xdot-util"
# MQTT server
-#IMAGE_INSTALL += "mosquitto"
-IMAGE_INSTALL += "mosquitto mosquitto-clients"
+IMAGE_INSTALL_append = "mosquitto mosquitto-clients"
# Perl support
-IMAGE_INSTALL += "perl"
-IMAGE_INSTALL += "perl-module-io perl-module-fcntl"
+IMAGE_INSTALL_append = "perl"
+IMAGE_INSTALL_append = "perl-module-io perl-module-fcntl"
# not in meta-oe or oe-core...
-#IMAGE_INSTALL += "libdevice-serialport-perl"
-#IMAGE_INSTALL += "libexpect-perl"
+#IMAGE_INSTALL_append = "libdevice-serialport-perl"
+#IMAGE_INSTALL_append = "libexpect-perl"
# Python support
-IMAGE_INSTALL += "python"
+IMAGE_INSTALL_append = "python"
# Python modules
-IMAGE_INSTALL += "python-argparse \
+IMAGE_INSTALL_append = "python-argparse \
python-compression \
python-dateutil \
python-html \
@@ -62,34 +61,34 @@ python-xml \
"
# Ruby support
-IMAGE_INSTALL += "ruby"
+IMAGE_INSTALL_append = "ruby"
-IMAGE_INSTALL += "ruby-sqlite3"
-IMAGE_INSTALL += "ruby-serialport"
+IMAGE_INSTALL_append = "ruby-sqlite3"
+IMAGE_INSTALL_append = "ruby-serialport"
# OpenJDK Java runtime
-# IMAGE_INSTALL += "openjdk-8"
+# IMAGE_INSTALL_append = "openjdk-8"
# OpenJDK with JamVM VM (Multi-Tech default)
-# IMAGE_INSTALL += "jamvm"
+# IMAGE_INSTALL_append = "jamvm"
# OpenJDK with CACAO VM (run with 'java -cacao')
-# IMAGE_INSTALL += "openjdk-7-vm-cacao"
+# IMAGE_INSTALL_append = "openjdk-7-vm-cacao"
# OpenJDK Zero VM (run with 'java -zero')
-# IMAGE_INSTALL += "openjdk-7-vm-zero"
+# IMAGE_INSTALL_append = "openjdk-7-vm-zero"
# PHP support
-IMAGE_INSTALL += "php php-cli php-fpm"
+IMAGE_INSTALL_append = "php php-cli php-fpm"
# Node.js support
-IMAGE_INSTALL += "nodejs nodejs-npm"
+IMAGE_INSTALL_append = "nodejs nodejs-npm"
# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
+IMAGE_INSTALL_append = "sms-utils"
# Multi-Tech GPS Utility
-IMAGE_INSTALL += "venus-gps"
-IMAGE_INSTALL += "pps-tools"
-IMAGE_INSTALL += "dnsmasq bluez5-pand bluez5-rfcomm"
+IMAGE_INSTALL_append = "venus-gps"
+IMAGE_INSTALL_append = "pps-tools"
+IMAGE_INSTALL_append = "dnsmasq bluez5-pand bluez5-rfcomm"
# When ntp is to use the GPS, gps-utils is required
-IMAGE_INSTALL += "gpsd libgps24 libgps ntp ntp-utils gpspipe gps-utils"
+IMAGE_INSTALL_append = "gpsd libgps24 libgps ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += "lxfp uvccapture"
+IMAGE_INSTALL_append = "lxfp uvccapture"
diff --git a/recipes-core/images/mlinux-mono-image.bb b/recipes-core/images/mlinux-mono-image.bb
index f15d7d2..c5af04d 100644
--- a/recipes-core/images/mlinux-mono-image.bb
+++ b/recipes-core/images/mlinux-mono-image.bb
@@ -1,3 +1,3 @@
require mlinux-base-image.bb
-IMAGE_INSTALL += "mono mono-helloworld"
+IMAGE_INSTALL_append = "mono mono-helloworld"
diff --git a/recipes-core/images/mlinux-mtcap-debug-image.bb b/recipes-core/images/mlinux-mtcap-debug-image.bb
index 48009ae..8a3f8f6 100644
--- a/recipes-core/images/mlinux-mtcap-debug-image.bb
+++ b/recipes-core/images/mlinux-mtcap-debug-image.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "mLinux Conduit Access Point debug image"
require mlinux-mtcap-image.bb
# Extra stuff to install
-IMAGE_INSTALL += "lora-network-server-mtcap \
+IMAGE_INSTALL_append = "lora-network-server-mtcap \
lora-gateway-utils \
lora-query \
mosquitto mosquitto-clients \
diff --git a/recipes-core/images/mlinux-mtcap-image.bb b/recipes-core/images/mlinux-mtcap-image.bb
index d318a8e..0b0c8a0 100644
--- a/recipes-core/images/mlinux-mtcap-image.bb
+++ b/recipes-core/images/mlinux-mtcap-image.bb
@@ -5,14 +5,15 @@ require mtcap-modules.inc
# For now we don't put this in MTR or AEP
# Password restrictions library from Redhat
-IMAGE_INSTALL += "libpwquality"
+IMAGE_INSTALL_append = "libpwquality"
FILESYSTEM_FEATURES = "dosfstools \
cifs-utils \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = " \
+ bridge-utils \
inetutils-ftp \
openssl \
rsync \
@@ -39,7 +40,7 @@ WIFI_FEATURES = "libnl \
wilc1000 \
"
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -50,7 +51,8 @@ MULTITECH_FEATURES += " \
annex-client \
"
-IMAGE_INSTALL += "lora-gateway-utils \
+IMAGE_INSTALL_append = " \
+ lora-gateway-utils \
lora-query \
lora-packet-forwarder \
lora-network-server \
@@ -64,11 +66,11 @@ MISC_FEATURES = "minicom lrzsz nano lxfp"
# Someday add wifi features
# ${WIFI_FEATURES}
#
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${FILESYSTEM_FEATURES} \
${TIME_FEATURES} \
${MISC_FEATURES} \
"
# Multi-Tech SMS Utility (see http://git.multitech.net)
-IMAGE_INSTALL += "sms-utils"
+IMAGE_INSTALL_append = "sms-utils"
diff --git a/recipes-core/images/mlinux-mtr-image.bb b/recipes-core/images/mlinux-mtr-image.bb
index 9fa719a..6c2fd90 100644
--- a/recipes-core/images/mlinux-mtr-image.bb
+++ b/recipes-core/images/mlinux-mtr-image.bb
@@ -9,7 +9,7 @@ FILESYSTEM_FEATURES = "dosfstools \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = "bridge-utils \
inetutils-ftp \
openssl \
rsync \
@@ -46,7 +46,7 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
# radio-cmd: supports cellular radio activation and other configuration commands
# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -57,7 +57,7 @@ MULTITECH_FEATURES += " \
MISC_FEATURES = "minicom lrzsz nano"
# Extra stuff to install
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${WIFI_FEATURES} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \
diff --git a/recipes-core/images/mlinux-mtrv1-image.bb b/recipes-core/images/mlinux-mtrv1-image.bb
index a5deb99..fd1ea6a 100644
--- a/recipes-core/images/mlinux-mtrv1-image.bb
+++ b/recipes-core/images/mlinux-mtrv1-image.bb
@@ -9,7 +9,7 @@ FILESYSTEM_FEATURES = "dosfstools \
lsof \
"
-NETWORKING_FEATURES += "bridge-utils \
+NETWORKING_FEATURES_append = "bridge-utils \
inetutils-ftp \
openssl \
rsync \
@@ -46,7 +46,7 @@ TIME_FEATURES = "tzdata tzdata-africa tzdata-americas tzdata-antarctica tzdata-a
# radio-cmd: supports cellular radio activation and other configuration commands
# radio-query: queries cellular radio for common info (IMEI, RSSI, etc)
# jsparser: command line tool to parse JSON files
-MULTITECH_FEATURES += " \
+MULTITECH_FEATURES_append = " \
u-boot-linux-utils \
mlinux-scripts \
reset-handler \
@@ -57,10 +57,10 @@ MULTITECH_FEATURES += " \
MISC_FEATURES = "minicom lrzsz nano"
# Extra stuff to install
-IMAGE_INSTALL += "kernel-module-rs9113 rs9113-util rs9113-autostart"
-IMAGE_INSTALL += "gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
+IMAGE_INSTALL_append = "kernel-module-rs9113 rs9113-util rs9113-autostart"
+IMAGE_INSTALL_append = "gpsd libgps libgps24 ntp ntp-utils gpspipe gps-utils"
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
${WIFI_FEATURES} \
${BLUETOOTH_FEATURES} \
${FILESYSTEM_FEATURES} \
diff --git a/recipes-core/images/mlinux-rs9113-base-image.bb b/recipes-core/images/mlinux-rs9113-base-image.bb
index ef565b6..37a0c76 100644
--- a/recipes-core/images/mlinux-rs9113-base-image.bb
+++ b/recipes-core/images/mlinux-rs9113-base-image.bb
@@ -2,4 +2,4 @@ require mlinux-base-image.bb
DESCRIPTION = "mLinux base image with rs9113 drivers"
# Extra stuff to install
-IMAGE_INSTALL += "kernel-module-rs9113 rs9113-autostart rs9113-util"
+IMAGE_INSTALL_append = "kernel-module-rs9113 rs9113-autostart rs9113-util"
diff --git a/recipes-core/images/mlinux-rs9113-factory-image.bb b/recipes-core/images/mlinux-rs9113-factory-image.bb
index 3ab950c..789a81b 100644
--- a/recipes-core/images/mlinux-rs9113-factory-image.bb
+++ b/recipes-core/images/mlinux-rs9113-factory-image.bb
@@ -2,4 +2,4 @@ require mlinux-factory-image.bb
DESCRIPTION = "mLinux factory image with rs9113 drivers"
# Extra stuff to install
-IMAGE_INSTALL += "dnsmasq bluez5-noinst-tools python-dbus kernel-module-rs9113 rs9113-autostart rs9113-util"
+IMAGE_INSTALL_append = "dnsmasq bluez5-noinst-tools python-dbus kernel-module-rs9113 rs9113-autostart rs9113-util"
diff --git a/recipes-core/images/mlinux-sdk.bb b/recipes-core/images/mlinux-sdk.bb
index cb3566f..503f77a 100644
--- a/recipes-core/images/mlinux-sdk.bb
+++ b/recipes-core/images/mlinux-sdk.bb
@@ -2,4 +2,4 @@
require mlinux-factory-image.bb
DESCRIPTION = "mLinux SDK"
-IMAGE_INSTALL += "boost"
+IMAGE_INSTALL_append = "boost"
diff --git a/recipes-core/images/mtcap-modules.inc b/recipes-core/images/mtcap-modules.inc
index 8cdfea4..ed3ca51 100644
--- a/recipes-core/images/mtcap-modules.inc
+++ b/recipes-core/images/mtcap-modules.inc
@@ -5,7 +5,7 @@
# modules that are dependency's
# of other modules.
-IMAGE_INSTALL += " \
+IMAGE_INSTALL_append = " \
kernel-module-8021q \
kernel-module-af-alg \
kernel-module-algif-hash \