summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2022-12-02 14:52:41 -0600
committerJohn Klug <john.klug@multitech.com>2023-05-24 16:33:24 -0500
commit5a4b14ebe4e00224d67823e28a426e4dde63cfcb (patch)
tree932de14d03ffd6250986e07dd15228b52672058a
parent03545140f31ea5231c80e8bec30e7bdc03e12dbe (diff)
downloadmeta-mlinux-atmel-5a4b14ebe4e00224d67823e28a426e4dde63cfcb.tar.gz
meta-mlinux-atmel-5a4b14ebe4e00224d67823e28a426e4dde63cfcb.tar.bz2
meta-mlinux-atmel-5a4b14ebe4e00224d67823e28a426e4dde63cfcb.zip
Add mLinux init script to mLinux minimal image
-rw-r--r--recipes-core/images/mlinux-minimal-image.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-core/images/mlinux-minimal-image.bb b/recipes-core/images/mlinux-minimal-image.bb
index 7d654e2..1a75424 100644
--- a/recipes-core/images/mlinux-minimal-image.bb
+++ b/recipes-core/images/mlinux-minimal-image.bb
@@ -8,6 +8,7 @@ inherit core-image
inherit mlinux-image
IMAGE_LINGUAS = ""
+SSH_SERVER_INIT ??= " openssh-sshd-mlinit"
IMAGE_FEATURES_append = " ssh-server-openssh package-management"
# Don't wipe out CORE_FEATURES from minimal image
@@ -31,7 +32,7 @@ CORE_FEATURES_append = " \
${MLINUX_OVERLAYFS} \
"
-CORE_FEATURES_append = " mtd-utils mtd-utils-jffs2 fstab-jffs2"
+CORE_FEATURES_append = " mtd-utils mtd-utils-jffs2 fstab-jffs2 ${SSH_SERVER_INIT}"
# All except old MTR
CORE_FEATURES_append_mtcap = " mt-dt-overlay "