summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-12-01 08:09:47 -0600
committerJason Reiss <jreiss@multitech.com>2016-12-01 08:09:47 -0600
commit36a54c9b251e5b2592183ce3ff447e5285f095b9 (patch)
tree0bb20e7679878396047f4305eda43f0c03ae3e03
parenta0d92e95f8b2438660c09cb8955362234fb1f1ea (diff)
downloadmeta-mlinux-atmel-36a54c9b251e5b2592183ce3ff447e5285f095b9.tar.gz
meta-mlinux-atmel-36a54c9b251e5b2592183ce3ff447e5285f095b9.tar.bz2
meta-mlinux-atmel-36a54c9b251e5b2592183ce3ff447e5285f095b9.zip
lora: remove JIT power check from packet forwarder. libloragw will pick the closest support power level from the LUT
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-remove-jit-power-check.patch24
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-remove-jit-power-check.patch b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-remove-jit-power-check.patch
new file mode 100644
index 0000000..cbb226b
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/lora-packet-forwarder-remove-jit-power-check.patch
@@ -0,0 +1,24 @@
+diff --git a/lora_pkt_fwd/src/lora_pkt_fwd.c b/lora_pkt_fwd/src/lora_pkt_fwd.c
+index 1c54d57..1e74d7f 100644
+--- a/lora_pkt_fwd/src/lora_pkt_fwd.c
++++ b/lora_pkt_fwd/src/lora_pkt_fwd.c
+@@ -2360,19 +2360,6 @@ void thread_down(void) {
+ jit_result = JIT_ERROR_TX_FREQ;
+ MSG("ERROR: Packet REJECTED, unsupported frequency - %u (min:%u,max:%u)\n", txpkt.freq_hz, tx_freq_min[txpkt.rf_chain], tx_freq_max[txpkt.rf_chain]);
+ }
+- if (jit_result == JIT_ERROR_OK) {
+- for (i=0; i<txlut.size; i++) {
+- if (txlut.lut[i].rf_power == txpkt.rf_power) {
+- /* this RF power is supported, we can continue */
+- break;
+- }
+- }
+- if (i == txlut.size) {
+- /* this RF power is not supported */
+- jit_result = JIT_ERROR_TX_POWER;
+- MSG("ERROR: Packet REJECTED, unsupported RF power for TX - %d\n", txpkt.rf_power);
+- }
+- }
+
+ /* insert packet to be sent into JIT queue */
+ if (jit_result == JIT_ERROR_OK) {
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
index cafa265..85fb8e3 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_3.0.0.bb
@@ -20,6 +20,7 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://global_conf.json.3.0.0.MTCAP-LORA-1-5.EU868.basic \
file://local_conf.json \
file://lora-packet-forwarder-add-spi-dev-path.patch \
+ file://lora-packet-forwarder-remove-jit-power-check.patch \
"
S = "${WORKDIR}/git"