summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Maki <jmaki@multitech.com>2010-04-23 15:38:24 -0500
committerJames Maki <jmaki@multitech.com>2010-04-23 15:38:24 -0500
commit5c8e5985871496ae41340e271c58b1e2810fc869 (patch)
tree7dabde71afafba9b6a73b74e84c196a35c3835f8 /configure.in
downloadhelloworld-autotools-5c8e5985871496ae41340e271c58b1e2810fc869.tar.gz
helloworld-autotools-5c8e5985871496ae41340e271c58b1e2810fc869.tar.bz2
helloworld-autotools-5c8e5985871496ae41340e271c58b1e2810fc869.zip
first commit
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..6446b5c
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,15 @@
+AC_INIT([src/helloworld.c])
+AM_INIT_AUTOMAKE([helloworld], [1.0.0])
+AM_CONFIG_HEADER([config.h])
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+AC_HEADER_STDC
+
+AC_CHECK_HEADERS([unistd.h getopt.h errno.h time.h], [],AC_MSG_ERROR([
+required header missing]))
+
+AC_OUTPUT([Makefile src/Makefile])
+