summaryrefslogtreecommitdiff
path: root/multitech/recipes/lighttpd/lighttpd_1.4.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'multitech/recipes/lighttpd/lighttpd_1.4.35.bb')
-rw-r--r--multitech/recipes/lighttpd/lighttpd_1.4.35.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/multitech/recipes/lighttpd/lighttpd_1.4.35.bb b/multitech/recipes/lighttpd/lighttpd_1.4.35.bb
new file mode 100644
index 0000000..6ff0192
--- /dev/null
+++ b/multitech/recipes/lighttpd/lighttpd_1.4.35.bb
@@ -0,0 +1,66 @@
+SUMMARY = "Lightweight high-performance web server"
+HOMEPAGE = "http://www.lighttpd.net/"
+BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
+
+PR = "r1"
+
+SECTION = "net"
+DEPENDS = "zlib libpcre"
+RDEPENDS_${PN} += " \
+ lighttpd-module-access \
+ lighttpd-module-accesslog \
+ lighttpd-module-indexfile \
+ lighttpd-module-dirlisting \
+ lighttpd-module-staticfile \
+"
+
+
+SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
+ file://index.html \
+ file://lighttpd.conf \
+ file://lighttpd \
+ file://pkgconfig.patch \
+ "
+
+SRC_URI[md5sum] = "f7a88130ee9984b421ad8aa80629750a"
+SRC_URI[sha256sum] = "4a71c1f6d8af41ed894b507720c4c17184dc320590013881d5170ca7f15c5bf7"
+
+EXTRA_OECONF = " \
+ --without-bzip2 \
+ --without-ldap \
+ --without-lua \
+ --without-memcache \
+ --with-pcre \
+ --without-webdav-props \
+ --without-webdav-locks \
+ --with-openssl \
+ --with-openssl-libs=${STAGING_LIBDIR} \
+ --disable-static \
+"
+
+inherit autotools pkgconfig update-rc.d gettext
+
+INITSCRIPT_NAME = "lighttpd"
+INITSCRIPT_PARAMS = "defaults 70"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
+ install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
+}
+
+FILES_${PN} += "${sysconfdir} /www"
+
+CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
+
+PACKAGES_DYNAMIC = "lighttpd-module-*"
+
+python populate_packages_prepend () {
+ lighttpd_libdir = bb.data.expand('${libdir}', d)
+ do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
+}
+