summaryrefslogtreecommitdiff
path: root/multitech/recipes/compat-wireless/ti-compat-wireless-wl12xx_r5.sp7.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'multitech/recipes/compat-wireless/ti-compat-wireless-wl12xx_r5.sp7.01.bb')
-rw-r--r--multitech/recipes/compat-wireless/ti-compat-wireless-wl12xx_r5.sp7.01.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/multitech/recipes/compat-wireless/ti-compat-wireless-wl12xx_r5.sp7.01.bb b/multitech/recipes/compat-wireless/ti-compat-wireless-wl12xx_r5.sp7.01.bb
new file mode 100644
index 0000000..c8a9bd5
--- /dev/null
+++ b/multitech/recipes/compat-wireless/ti-compat-wireless-wl12xx_r5.sp7.01.bb
@@ -0,0 +1,63 @@
+# This is a TI specific version of the compat-wireless recipe using a
+# compat-wireless package created from the TI Systems Tested mac80211 releases.
+
+DESCRIPTION = "ti compat-wireless drivers"
+HOMEPAGE = "https://github.com/TI-OpenLink"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=d7810fab7487fb0aad327b76f1be7cd7"
+
+RDEPENDS_${PN} = "wireless-tools"
+
+inherit module
+
+LOCAL_PR = ".1"
+MACHINE_KERNEL_PR_append = "${LOCAL_PR}"
+
+TAG="ol_R5.SP7.01"
+
+S = "${WORKDIR}/compat-wireless-${TAG}"
+
+SRC_URI = "http://www.multitech.net/corecdp/sources/TI-OpenLink.compat-wireless_${TAG}.tar.gz;name=compat-wireless \
+ http://www.multitech.net/corecdp/sources/TI-OpenLink.compat_${TAG}.tar.gz;name=compat \
+ http://www.multitech.net/corecdp/sources/TI-OpenLink.wl12xx_${TAG}.tar.gz;name=wl12xx \
+ file://0001-git-version-use-compat-base-tree.patch;patchdir=../wl12xx-${TAG} \
+ file://0001-compat-wireless-add-pm_runtime_enabled.patch;patchdir=../compat-${TAG} \
+ file://0001-wl12xx-additional-two-members-for-wl12xx_platform_da.patch;patchdir=../wl12xx-${TAG} \
+ "
+
+SRC_URI[compat-wireless.md5sum] = "935fa394ac9ad9d1673808f424b62b03"
+SRC_URI[compat-wireless.sha256sum] = "3481171a67b58b6637675a94701fd23c8716b431b76a9403061afe47fc256604"
+SRC_URI[compat.md5sum] = "9ef6945e22c296008dbdea8a544ec3f3"
+SRC_URI[compat.sha256sum] = "c33b1d73b4e6381d67255174ff37dc1ff2a81594f43903b22c56943437ae4443"
+SRC_URI[wl12xx.md5sum] = "3301da0ab7eeedf5d942d78652b84650"
+SRC_URI[wl12xx.sha256sum] = "98137f9ced94de839abef86eb1cbee068f362bd28c5190449ca15165dcad0ca5"
+
+#SRC_URI_append = "file://0001-wl12xx-Decrease-number-of-RX-transactions.patch;patchdir=../wl12xx-${TAG} \
+# file://0002-wl12xx-Decrease-number-of-TX-transactions.patch;patchdir=../wl12xx-${TAG} \
+#"
+
+# mts patches
+SRC_URI_append = "file://wl12xx-set-power-r5.sp7.01.patch;patchdir=../wl12xx-${TAG}"
+
+EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}"
+
+do_configure() {
+ cd ${S}
+ GIT_TREE="${WORKDIR}/wl12xx-${TAG}" GIT_COMPAT_TREE="${WORKDIR}/compat-${TAG}" ./scripts/admin-refresh.sh
+
+ # create versions manually since we aren't working in git repos so admin-refresh.sh doesn't set them
+ echo -e "${TAG}" > compat_version
+ echo -e "${TAG}" > compat_base_tree_version
+ echo "" > compat_base_tree
+
+ ./scripts/driver-select wl12xx
+}
+
+do_configure_append() {
+ sed -i "s#@./scripts/update-initramfs## " Makefile
+}
+
+do_install() {
+ oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
+}