summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2020-06-19 12:10:09 -0500
committerJason Reiss <jreiss@multitech.com>2020-06-19 12:10:09 -0500
commit44a0a126bc6439d6c6cfc1810429bb4b5c6afed6 (patch)
treeb8d9019f82b12200adacd5856a27c1947dccda1b /recipes-connectivity
parent612ffa7c85d856c9706064e62448a3debe5c3379 (diff)
downloadmeta-mlinux-44a0a126bc6439d6c6cfc1810429bb4b5c6afed6.tar.gz
meta-mlinux-44a0a126bc6439d6c6cfc1810429bb4b5c6afed6.tar.bz2
meta-mlinux-44a0a126bc6439d6c6cfc1810429bb4b5c6afed6.zip
lora: update lora-query, lora-basic-station and add mbedtls
Diffstat (limited to 'recipes-connectivity')
-rw-r--r--recipes-connectivity/lora/lora-basic-station/lora-basic-station-disable-device-mode.patch15
-rw-r--r--recipes-connectivity/lora/lora-basic-station/lora-basic-station-fix-clksrc-0.patch14
-rw-r--r--recipes-connectivity/lora/lora-basic-station/lora-basic-station-sys-linux-log-fix.patch14
-rw-r--r--recipes-connectivity/lora/lora-basic-station_2.0.5-1.bb (renamed from recipes-connectivity/lora/lora-basic-station_2.0.3.bb)7
-rw-r--r--recipes-connectivity/lora/lora-query/Makefile75
-rw-r--r--recipes-connectivity/lora/lora-query_1.0.6.bb (renamed from recipes-connectivity/lora/lora-query_1.0.4.bb)0
-rw-r--r--recipes-connectivity/mbedtls/mbedtls_2.13.0.bb42
7 files changed, 44 insertions, 123 deletions
diff --git a/recipes-connectivity/lora/lora-basic-station/lora-basic-station-disable-device-mode.patch b/recipes-connectivity/lora/lora-basic-station/lora-basic-station-disable-device-mode.patch
deleted file mode 100644
index d81d041..0000000
--- a/recipes-connectivity/lora/lora-basic-station/lora-basic-station-disable-device-mode.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/src/sx1301conf.c b/src/sx1301conf.c
-index bca649c..c2681a4 100644
---- a/src/sx1301conf.c
-+++ b/src/sx1301conf.c
-@@ -433,7 +433,10 @@ int sx1301conf_start (struct sx1301conf* sx1301conf, u4_t cca_region) {
- }
-
- LOG(MOD_RAL|INFO, "Station device: %s (PPS capture %sabled)", sx1301conf->device, sx1301conf->pps ? "en":"dis");
-+
-+#ifndef CFG_prod
- lgwx_device_mode = sys_deviceMode;
-+#endif
- int err = lgw_start();
- if( err == LGW_HAL_SUCCESS ) {
- lgw_reg_w(LGW_GPS_EN, sx1301conf->pps ? 1 : 0);
diff --git a/recipes-connectivity/lora/lora-basic-station/lora-basic-station-fix-clksrc-0.patch b/recipes-connectivity/lora/lora-basic-station/lora-basic-station-fix-clksrc-0.patch
deleted file mode 100644
index c534460..0000000
--- a/recipes-connectivity/lora/lora-basic-station/lora-basic-station-fix-clksrc-0.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/sx1301conf.c b/src/sx1301conf.c
-index bca649c..fe62351 100644
---- a/src/sx1301conf.c
-+++ b/src/sx1301conf.c
-@@ -193,7 +193,8 @@ static void parse_sx1301_conf (ujdec_t* D, struct sx1301conf* sx1301conf) {
- break;
- }
- case J_clksrc: {
- sx1301conf->boardconf.clksrc = uj_intRange(D, 0, LGW_RF_CHAIN_NB-1);
-+ sx1301conf->boardconf.clksrc = 0;
- break;
- }
- case J_tx_gain_lut: {
-
diff --git a/recipes-connectivity/lora/lora-basic-station/lora-basic-station-sys-linux-log-fix.patch b/recipes-connectivity/lora/lora-basic-station/lora-basic-station-sys-linux-log-fix.patch
deleted file mode 100644
index 83be080..0000000
--- a/recipes-connectivity/lora/lora-basic-station/lora-basic-station-sys-linux-log-fix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src-linux/sys_linux.c b/src-linux/sys_linux.c
-index f8286c8..7afc073 100644
---- a/src-linux/sys_linux.c
-+++ b/src-linux/sys_linux.c
-@@ -724,7 +724,7 @@ static int parseStationConf () {
- case J_nodc:
- case J_nodwell:
- case J_device_mode: {
-- LOG(MOD_S2E|WARNING, "Feature not supported in production level code (station.conf) - ignored: %s", D->field.name);
-- uj_skipValue(D);
-+ LOG(MOD_S2E|WARNING, "Feature not supported in production level code (station.conf) - ignored: %s", D.field.name);
-+ uj_skipValue(&D);
- break;
- }
diff --git a/recipes-connectivity/lora/lora-basic-station_2.0.3.bb b/recipes-connectivity/lora/lora-basic-station_2.0.5-1.bb
index 2db6a14..f0df90b 100644
--- a/recipes-connectivity/lora/lora-basic-station_2.0.3.bb
+++ b/recipes-connectivity/lora/lora-basic-station_2.0.5-1.bb
@@ -9,16 +9,13 @@ DEPENDS = "lora-gateway logrotate lora-logging mbedtls"
RDEPENDS_${PN} += "bash"
PR = "r1"
-SRCREV = "v${PV}"
+SRCREV = "${PV}"
-SRC_URI = "git://github.com/lorabasics/basicstation.git;protocol=git \
+SRC_URI = "git://github.com/MultiTechSystems/basicstation.git;protocol=git;branch=master \
file://setup.gmk \
file://lora-basic-station.init \
file://lora-basic-station.default \
file://tc.uri \
- file://lora-basic-station-disable-device-mode.patch \
- file://lora-basic-station-sys-linux-log-fix.patch \
- file://lora-basic-station-fix-clksrc-0.patch \
"
diff --git a/recipes-connectivity/lora/lora-query/Makefile b/recipes-connectivity/lora/lora-query/Makefile
deleted file mode 100644
index 2079a0d..0000000
--- a/recipes-connectivity/lora/lora-query/Makefile
+++ /dev/null
@@ -1,75 +0,0 @@
-
-includedir ?= /usr/include
-libdir ?= /usr/lib
-
-CFLAGS +=
-
-LIBS := -lmts -ljsoncpp -lpthread
-
-OBJS += \
-Version.o \
-main.o
-
-CPP_DEPS += \
-Version.d \
-main.d
-
-
-all: postbuild
-
-prebuild:
- @echo PRE-BUILD
- @echo 'Removing previous version components started'
- -$(RM) Version.o
- -$(RM) Version.d
- -$(RM) Version.cpp
- @echo 'Removing previous version components complete'
- @echo ' '
-
-postbuild: mainbuild
- @echo POST-BUILD
- @echo ' '
-
-mainbuild: prebuild
- @echo MAIN-BUILD
- @$(MAKE) --no-print-directory target
-
-target: $(OBJS)
- @echo 'Building target: $@'
- $(CXX) $(CFLAGS) $(LDFLAGS) -o lora-query $(OBJS) $(LIBS)
- @echo 'Finished building target: $@'
- @echo ' '
-
-Version.o: Version.cpp
- @echo 'Building file: $<'
- $(CXX) $(CFLAGS) -Iinclude -Wall -c -std=c++0x -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
-Version.cpp:
- @echo 'Creating file: Version.cpp'
- /bin/echo -e "//Pre-Build Auto-Generated Source\n#include \"Version.h\"\n\nconst std::string Version::version(\"$(shell git describe)\");" > Version.cpp
- @echo 'Finished creating: Version.cpp'
- @echo ' '
-
-main.o: main.cpp
- @echo 'Building file: $<'
- $(CXX) $(CFLAGS) -I=$(includedir)/jsoncpp -Wall -c -std=c++0x -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o "$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
-install:
- install -d $(DESTDIR)/usr/bin
- install -m 0755 lora-query $(DESTDIR)/usr/bin
-
-strip:
- $(STRIP) lora-query
-
-clean:
- -$(RM) $(OBJS) $(CPP_DEPS) lora-query
- -@echo ' '
-
-.PHONY: all clean dependents install strip target
-.SECONDARY:
-
-
diff --git a/recipes-connectivity/lora/lora-query_1.0.4.bb b/recipes-connectivity/lora/lora-query_1.0.6.bb
index 60bcc42..60bcc42 100644
--- a/recipes-connectivity/lora/lora-query_1.0.4.bb
+++ b/recipes-connectivity/lora/lora-query_1.0.6.bb
diff --git a/recipes-connectivity/mbedtls/mbedtls_2.13.0.bb b/recipes-connectivity/mbedtls/mbedtls_2.13.0.bb
new file mode 100644
index 0000000..ff3f7f0
--- /dev/null
+++ b/recipes-connectivity/mbedtls/mbedtls_2.13.0.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Lightweight crypto and SSL/TLS library"
+DESCRIPTION = "mbedtls is a lean open source crypto library \
+for providing SSL and TLS support in your programs. It offers \
+an intuitive API and documented header files, so you can actually \
+understand what the code does. It features: \
+ \
+ - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
+ Camellia and XTEA \
+ - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
+ - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
+ - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
+ ECDSA and ECDH \
+ - SSL v3 and TLS 1.0, 1.1 and 1.2 \
+ - Abstraction layers for ciphers, hashes, public key operations, \
+ platform abstraction and threading \
+"
+
+HOMEPAGE = "https://tls.mbed.org/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=302d50a6369f5f22efdb674db908167a"
+
+SECTION = "libs"
+
+SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-apache.tgz"
+
+SRC_URI[md5sum] = "659d96bb03012ca6db414a9137fcdbd6"
+SRC_URI[sha256sum] = "593b4e4d2e1629fc407ab4750d69fa309a0ddb66565dc3deb5b60eddbdeb06da"
+
+inherit cmake
+
+PACKAGECONFIG ??= "shared-libs programs"
+PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-USE_SHARED_MBEDTLS_LIBRARY=OFF"
+PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF"
+
+EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}"
+
+PROVIDES += "polarssl"
+RPROVIDES_${PN} = "polarssl"
+
+PACKAGES =+ "${PN}-programs"
+FILES_${PN}-programs = "${bindir}/"