summaryrefslogtreecommitdiff
path: root/recipes-connectivity
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-09-02 07:31:40 -0500
committerJason Reiss <jreiss@multitech.com>2016-09-02 07:31:40 -0500
commit1ab31a83258a119b93c71b7b331ba463a870d7bd (patch)
tree1d5639610f48c6ad2481fa3f3a6ad8d99824d369 /recipes-connectivity
parentca697c01ef93c2a08493684b02656d3f93ca1a9d (diff)
downloadmeta-mlinux-1ab31a83258a119b93c71b7b331ba463a870d7bd.tar.gz
meta-mlinux-1ab31a83258a119b93c71b7b331ba463a870d7bd.tar.bz2
meta-mlinux-1ab31a83258a119b93c71b7b331ba463a870d7bd.zip
lora: update network server to 1.0.12, add license info to packet forwarder install
Diffstat (limited to 'recipes-connectivity')
-rwxr-xr-xrecipes-connectivity/lora/lora-network-server/lora-network-server.init4
-rw-r--r--recipes-connectivity/lora/lora-network-server_1.0.12.bb (renamed from recipes-connectivity/lora/lora-network-server_1.0.11.bb)4
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder/README.md38
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb5
4 files changed, 46 insertions, 5 deletions
diff --git a/recipes-connectivity/lora/lora-network-server/lora-network-server.init b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
index 4baad10..4b80dc7 100755
--- a/recipes-connectivity/lora/lora-network-server/lora-network-server.init
+++ b/recipes-connectivity/lora/lora-network-server/lora-network-server.init
@@ -55,9 +55,9 @@ do_start() {
mkdir -p $run_dir/1
# start network server
start-stop-daemon --start --background --make-pidfile \
- --pidfile $net_server_pidfile --exec $net_server -- \
+ --pidfile $net_server_pidfile --startas /bin/bash -- -c "exec $net_server \
-c $conf_file --lora-eui $lora_eui --lora-path $run_dir --db $conf_db \
- --noconsole -l $net_server_log
+ --noconsole -l $net_server_log >> $net_server_log 2>&1"
sleep 2
# start packet forwarder
start-stop-daemon --start --background --make-pidfile \
diff --git a/recipes-connectivity/lora/lora-network-server_1.0.11.bb b/recipes-connectivity/lora/lora-network-server_1.0.12.bb
index 05e392b..4873822 100644
--- a/recipes-connectivity/lora/lora-network-server_1.0.11.bb
+++ b/recipes-connectivity/lora/lora-network-server_1.0.12.bb
@@ -13,8 +13,8 @@ SRC_URI = "http://multitech.net/downloads/lora-network-server_${TUNE_PKGARCH}_${
file://lora-network-server.logrotate.conf \
"
-SRC_URI[md5sum] = "87f2412864a5174b3c2b8a0f2da96fc1"
-SRC_URI[sha256sum] = "fc400cac0af7e69ae3d016d3ea9a2bdda310afb4ed6089bfed923509f0f46623"
+SRC_URI[md5sum] = "4d9e6a1b5e121f9af77b4257d7972f1d"
+SRC_URI[sha256sum] = "c625ed2414c8e1711a3da1cec4c8ced70bcbbab24c9461106cdf9576ca3f2864"
# binaries are already stripped, so suppress warning
INSANE_SKIP_${PN} = "already-stripped"
diff --git a/recipes-connectivity/lora/lora-packet-forwarder/README.md b/recipes-connectivity/lora/lora-packet-forwarder/README.md
new file mode 100644
index 0000000..c927c60
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder/README.md
@@ -0,0 +1,38 @@
+
+
+(c) Senet, Inc 2016
+
+
+
+3rd Party Licenses
+------------------
+
+This software incorporates the lora_gateway software which requires the
+following statement to be included in its distribution.
+
+Copyright (c) 2013, SEMTECH S.A.
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ * Neither the name of the Semtech corporation nor the
+ names of its contributors may be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL SEMTECH S.A. BE LIABLE FOR ANY
+DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
diff --git a/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb b/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb
index bbb379d..62e6f4c 100644
--- a/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb
+++ b/recipes-connectivity/lora/lora-packet-forwarder_1.4.1.bb
@@ -6,7 +6,7 @@ SECTION = "console/utils"
LICENSE = "SEMTECH"
LIC_FILES_CHKSUM = "file://LICENSE;md5=22af7693d7b76ef0fc76161c4be76c45"
DEPENDS = "lora-gateway"
-PR = "r9"
+PR = "r10"
# tag v1.4.1
SRCREV = "0011a60759a7d81656a5393e97089daab1ff1a81"
@@ -19,6 +19,7 @@ SRC_URI = "git://github.com/Lora-net/packet_forwarder.git;protocol=git \
file://lora-packet-forwarder-mts-enhancements.patch \
file://lora-packet-forwarder-synch-word.patch \
file://lora-packet-forwarder-add-queue.patch \
+ file://README.md \
"
S = "${WORKDIR}/git"
@@ -41,6 +42,8 @@ do_install() {
install -m 755 beacon_pkt_fwd/beacon_pkt_fwd ${D}${LORA_DIR}/
install -m 755 util_sink/util_sink ${D}${LORA_DIR}/
install -m 755 util_ack/util_ack ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/README.md ${D}${LORA_DIR}/
+
# skip util_tx_test since it conflicts with one in lora-gateway
# install -m 755 util_tx_test/util_tx_test ${D}${LORA_DIR}/