summaryrefslogtreecommitdiff
path: root/recipes-connectivity/ppp
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-09-05 19:52:26 -0500
committerJohn Klug <john.klug@multitech.com>2017-09-14 17:41:52 -0500
commitef26845544975527a0ced7381ca7a0fc8b0c8888 (patch)
treeb063466157c023874ac21a12acb4aece405d4ab7 /recipes-connectivity/ppp
parent380abd487551ecf881a31c78eb5ad76fce781b6d (diff)
downloadmeta-mlinux-ef26845544975527a0ced7381ca7a0fc8b0c8888.tar.gz
meta-mlinux-ef26845544975527a0ced7381ca7a0fc8b0c8888.tar.bz2
meta-mlinux-ef26845544975527a0ced7381ca7a0fc8b0c8888.zip
Get ppp to work from boot up
Diffstat (limited to 'recipes-connectivity/ppp')
-rw-r--r--recipes-connectivity/ppp/files/default8
-rw-r--r--recipes-connectivity/ppp/files/init.patch34
-rw-r--r--recipes-connectivity/ppp/files/poff.patch12
-rw-r--r--recipes-connectivity/ppp/ppp_%.bbappend17
4 files changed, 71 insertions, 0 deletions
diff --git a/recipes-connectivity/ppp/files/default b/recipes-connectivity/ppp/files/default
new file mode 100644
index 0000000..6cc92df
--- /dev/null
+++ b/recipes-connectivity/ppp/files/default
@@ -0,0 +1,8 @@
+# Check to see if the SIM is registered before using ppp.
+# Need this if using a cellular connection.
+CHECKREGISTRATION=1
+# Note that boot will not complete until
+# ppp completes, and the PPPTIMEOUT is the
+# maximum wait time for the SIM to register
+# for cellular PPP.
+PPPTIMEOUT=60
diff --git a/recipes-connectivity/ppp/files/init.patch b/recipes-connectivity/ppp/files/init.patch
new file mode 100644
index 0000000..e74e981
--- /dev/null
+++ b/recipes-connectivity/ppp/files/init.patch
@@ -0,0 +1,34 @@
+diff -Naru old/init new/init
+--- old/init 2017-09-05 19:07:19.810885424 -0500
++++ new/init 2017-09-05 19:08:05.106884083 -0500
+@@ -8,11 +8,29 @@
+
+ test -x /usr/sbin/pppd -a -f /etc/ppp/ppp_on_boot || exit 0
+ if [ -x /etc/ppp/ppp_on_boot ]; then RUNFILE=1; fi
+-
++: ${PPPTIMEOUT:=60}
++logger timeout is $PPPTIMEOUT
++[ -f /etc/default/ppp ] && . /etc/default/ppp
+ case "$1" in
+ start)
++ t0=($(cat /proc/uptime))
++ if (( CHECKREGISTRATION == 1 )) ; then while : ; do
++ REG=$(/usr/bin/radio-query --netreg)
++ [[ $REG == "REGISTERED" ]] && break
++ t1=($(cat /proc/uptime))
++ diff=$(awk "BEGIN{print int($t1-$t0)}")
++ logger -s "Modem not ready. Waited $diff of $PPPTIMEOUT seconds"
++ if ((diff > PPPTIMEOUT)) ; then
++ logger -s "Timed out waiting for modem registration"
++ exit 1
++ fi
++ sleep 1
++ done ; fi
++
++ logger "Starting up PPP link: pppd"
+ echo -n "Starting up PPP link: pppd"
+ if [ "$RUNFILE" = "1" ]; then
++ logger "ppp_on_boot"
+ /etc/ppp/ppp_on_boot
+ else
+ pppd call provider
diff --git a/recipes-connectivity/ppp/files/poff.patch b/recipes-connectivity/ppp/files/poff.patch
new file mode 100644
index 0000000..2385886
--- /dev/null
+++ b/recipes-connectivity/ppp/files/poff.patch
@@ -0,0 +1,12 @@
+diff -Naru old/poff new/poff
+--- old/poff 2017-09-05 19:07:11.630885666 -0500
++++ new/poff 2017-09-05 19:08:09.586883950 -0500
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+
+ # Lets see how many pppds are running....
+-set -- `cat /var/run/ppp*.pid 2>/dev/null`
++set -- `cat /var/run/ppp[0-9]*.pid 2>/dev/null`
+
+ case $# in
+ 0) # pppd only creates a pid file once ppp is up, so let's try killing pppd
diff --git a/recipes-connectivity/ppp/ppp_%.bbappend b/recipes-connectivity/ppp/ppp_%.bbappend
new file mode 100644
index 0000000..54b2de1
--- /dev/null
+++ b/recipes-connectivity/ppp/ppp_%.bbappend
@@ -0,0 +1,17 @@
+SRC_URI_append = "\
+ file://init.patch;patchdir=.. \
+ file://poff.patch;patchdir=.. \
+ file://default"
+
+PR = "r9"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+FILES_${PN} += "/etc/default/ppp"
+
+CONFFILES_${PN} += "${sysconfdir}/default/ppp"
+
+do_install_append() {
+ install -d -m 0755 ${D}/${sysconfdir}/default/
+ install -m 644 ${WORKDIR}/default ${D}/${sysconfdir}/default/ppp
+}