summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2018-04-19 14:56:37 -0500
committerHarsh Sharma <harsh.sharma@multitech.com>2018-04-19 14:56:37 -0500
commita1e89171c91479369af13134828c2fb4a4fd824f (patch)
treec56691abc962a60036062082f97f64563741a693 /recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
parent5dc0d8ffad8679293b059d219e49299fcc43cfc1 (diff)
downloadmeta-mlinux-a1e89171c91479369af13134828c2fb4a4fd824f.tar.gz
meta-mlinux-a1e89171c91479369af13134828c2fb4a4fd824f.tar.bz2
meta-mlinux-a1e89171c91479369af13134828c2fb4a4fd824f.zip
Added Lora 2.1 Packet forwarder support
Diffstat (limited to 'recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb')
-rw-r--r--recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
new file mode 100644
index 0000000..735204e
--- /dev/null
+++ b/recipes-connectivity/lora/lora-packet-forwarder-geolocation_5.1.0.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "LoRa Packet Forwarder Geolocation"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://mlinux4/LICENSE.TXT;md5=86776875df1423114abfcec938f3e565"
+DEPENDS ?= "lora-gateway-geolocation"
+RDEPENDS_${PN} += "bash"
+PR = "r1"
+
+SRCREV = "v${PV}"
+
+SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}.tar.gz \
+ file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_full_diversity_EU868 \
+ file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_full_diversity_JP920 \
+ file://global_conf.json.MTAC_LORA_2_1_loc_dual_antenna_8ch_partial_diversity_EU868 \
+ file://global_conf.json.MTAC_LORA_2_1_loc_single_antenna_16ch_EU868 \
+ file://global_conf.json.MTAC_LORA_2_1_loc_single_antenna_16ch_US915 \
+ file://global_conf.json.MTAC_LORA_2_1_loc_single_antenna_64ch_US915 \
+ file://global_conf.json.MTAC_LORA_2_1_loc_single_antenna_full_duplex_64ch_US915 \
+ file://global_conf.json.MTAC_LORA_2_1_test_dual_antenna_56ch_partial_diversity_EU868 \
+ file://global_conf.json.MTAC_LORA_2_1_test_single_antenna_16ch_16x1_EU868 \
+ file://global_conf.json.MTAC_LORA_2_1_test_single_antenna_64ch_64x1_EU868 \
+ file://global_conf.json.MTAC_LORA_2_1_test_single_antenna_64ch_8x8_EU868 \
+"
+
+SRC_URI[md5sum] = "6d347a6fc73827ca44d9d5a33c6e4c0d"
+SRC_URI[sha256sum] = "88bf470b142bfb7ac3a23a22690908b0a4757dd4587f5007aa292470999e3e6f"
+
+S = "${WORKDIR}"
+B = "${S}"
+
+LORA_DIR = "/opt/lora"
+
+export LGW_PATH = "${STAGING_LIBDIR}/lora"
+export LGW_INC = "${STAGING_INCDIR}/lora"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${LORA_DIR}
+ install -m 755 mlinux4/pkt_forwarder ${D}${LORA_DIR}/
+ install -m 755 ${WORKDIR}/global_conf.json.MTAC_LORA_2_1* ${D}${LORA_DIR}/
+ install -d ${D}${LORA_DIR}/forwarder-utils-geo
+ install -m 755 mlinux4/forwarder-utils-geo/* ${D}${LORA_DIR}/forwarder-utils-geo/
+}
+
+
+FILES_${PN} += "${LORA_DIR}"
+FILES_${PN}-dbg += "${LORA_DIR}/.debug ${LORA_DIR}/forwarder-utils-geo/.debug"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}