summaryrefslogtreecommitdiff
path: root/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
diff options
context:
space:
mode:
authorHarsh Sharma <harsh.sharma@multitech.com>2018-04-19 14:56:37 -0500
committerHarsh Sharma <harsh.sharma@multitech.com>2018-04-19 14:56:37 -0500
commita1e89171c91479369af13134828c2fb4a4fd824f (patch)
treec56691abc962a60036062082f97f64563741a693 /recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
parent5dc0d8ffad8679293b059d219e49299fcc43cfc1 (diff)
downloadmeta-mlinux-a1e89171c91479369af13134828c2fb4a4fd824f.tar.gz
meta-mlinux-a1e89171c91479369af13134828c2fb4a4fd824f.tar.bz2
meta-mlinux-a1e89171c91479369af13134828c2fb4a4fd824f.zip
Added Lora 2.1 Packet forwarder support
Diffstat (limited to 'recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb')
-rw-r--r--recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
new file mode 100644
index 0000000..28b8b56
--- /dev/null
+++ b/recipes-connectivity/lora/lora-gateway-geolocation_5.1.0.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "LoRa Gateway Geolocation library"
+PRIORITY = "optional"
+SECTION = "console/utils"
+# Semtech license is a modified BSD-style license
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://mlinux4/LICENSE.TXT;md5=86776875df1423114abfcec938f3e565"
+DEPENDS = ""
+PR = "r2"
+SRCREV = "v${PV}"
+
+SRC_URI = "http://multitech.net/downloads/lora-packet-forwarder-geolocation_arm926ejste_${PV}.tar.gz \
+ file://config.json \
+ file://config_64ch.json \
+ "
+
+SRC_URI[md5sum] = "6d347a6fc73827ca44d9d5a33c6e4c0d"
+SRC_URI[sha256sum] = "88bf470b142bfb7ac3a23a22690908b0a4757dd4587f5007aa292470999e3e6f"
+
+S = "${WORKDIR}"
+
+CFLAGS += "-Iinc -I."
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${includedir}/lora
+ install -d ${D}${libdir}/lora
+ install -m 0644 mlinux4/libsx1301ar/* ${D}${includedir}/lora
+
+ install -d ${D}/sbin
+ install -m 0755 mlinux4/gateway-utils-geo/fpga_flash_loader ${D}/sbin/sem-fpga-loader
+
+ install -d ${D}/opt/lora/
+ install -d ${D}/opt/lora/gateway-utils-geo
+ install -m 0755 mlinux4/gateway-utils-geo/* ${D}/opt/lora/gateway-utils-geo/
+ install -m 0755 ${WORKDIR}/config.json ${D}/opt/lora/gateway-utils-geo/
+ install -m 0755 ${WORKDIR}/config_64ch.json ${D}/opt/lora/gateway-utils-geo/
+}
+
+PACKAGES += "${PN}-utils ${PN}-utils-dbg"
+
+FILES_${PN} = "${libdir}/lora/lora-gw-geolocation-readme.md ${includedir}/lora /usr/lib/"
+FILES_${PN}-utils = "/opt/lora/gateway-utils-geo/* /sbin/sem-fpga-loader"
+FILES_${PN}-utils-dbg = "/opt/lora/gateway-utils-geo/.debug "
+FILES_${PN}-staticdev = "${libdir}/lora/libsx1301ar.a"
+
+# disable this on purpose for dev purposes
+do_rm_work() {
+ echo "skipping"
+}