summaryrefslogtreecommitdiff
path: root/recipes-connectivity/hostapd
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
committerJesse Gilles <jgilles@multitech.com>2014-11-04 11:51:34 -0600
commite243c30f04c18722dc65effe6d4f275a3f35de46 (patch)
tree807610ce8af0ead02681d6c3cc89d902ec941652 /recipes-connectivity/hostapd
downloadmeta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.gz
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.tar.bz2
meta-mlinux-e243c30f04c18722dc65effe6d4f275a3f35de46.zip
initial commit of mLinux layer
Diffstat (limited to 'recipes-connectivity/hostapd')
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon-1.0/default2
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon-1.0/init43
-rw-r--r--recipes-connectivity/hostapd/hostap-daemon_1.0.bbappend8
3 files changed, 53 insertions, 0 deletions
diff --git a/recipes-connectivity/hostapd/hostap-daemon-1.0/default b/recipes-connectivity/hostapd/hostap-daemon-1.0/default
new file mode 100644
index 0000000..0923a8c
--- /dev/null
+++ b/recipes-connectivity/hostapd/hostap-daemon-1.0/default
@@ -0,0 +1,2 @@
+# set to "yes" to start hostapd on boot
+START_ON_BOOT="no"
diff --git a/recipes-connectivity/hostapd/hostap-daemon-1.0/init b/recipes-connectivity/hostapd/hostap-daemon-1.0/init
new file mode 100644
index 0000000..a8d622f
--- /dev/null
+++ b/recipes-connectivity/hostapd/hostap-daemon-1.0/init
@@ -0,0 +1,43 @@
+#!/bin/sh
+DAEMON=/usr/sbin/hostapd
+NAME=hostapd
+DESC="HOSTAP Daemon"
+ARGS="/etc/hostapd.conf -B"
+
+test -f $DAEMON || exit 0
+
+[ -f /etc/default/$NAME ] && . /etc/default/$NAME
+
+if [ "$START_ON_BOOT" != "yes" ]; then
+ exit 0
+fi
+
+set -e
+
+case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+ start-stop-daemon -S -x $DAEMON -- $ARGS
+ echo "$NAME."
+ ;;
+ stop)
+ echo -n "Stopping $DESC: "
+ start-stop-daemon -K -x $DAEMON
+ echo "$NAME."
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ reload)
+ echo -n "Reloading $DESC: "
+ killall -HUP $(basename ${DAEMON})
+ echo "$NAME."
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-connectivity/hostapd/hostap-daemon_1.0.bbappend b/recipes-connectivity/hostapd/hostap-daemon_1.0.bbappend
new file mode 100644
index 0000000..48af903
--- /dev/null
+++ b/recipes-connectivity/hostapd/hostap-daemon_1.0.bbappend
@@ -0,0 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
+
+SRC_URI += "file://default"
+
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/default
+ install -m 644 ${WORKDIR}/default ${D}${sysconfdir}/default/hostapd
+}