summaryrefslogtreecommitdiff
path: root/recipes-connectivity/hostapd/hostapd_%.bbappend
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-08-18 10:13:26 -0500
committerJohn Klug <john.klug@multitech.com>2020-08-18 10:13:26 -0500
commite0b6b7444498fdef7151a4b363cf6eb89e1ec504 (patch)
tree79946c2609960e10a0b145beda3b8f62ec00134e /recipes-connectivity/hostapd/hostapd_%.bbappend
parent5101a0f32017c23707ea0b3aa2f650803b11a644 (diff)
downloadmeta-mlinux-e0b6b7444498fdef7151a4b363cf6eb89e1ec504.tar.gz
meta-mlinux-e0b6b7444498fdef7151a4b363cf6eb89e1ec504.tar.bz2
meta-mlinux-e0b6b7444498fdef7151a4b363cf6eb89e1ec504.zip
Add hostapd-extra package for setting channel and SSID
Diffstat (limited to 'recipes-connectivity/hostapd/hostapd_%.bbappend')
-rw-r--r--recipes-connectivity/hostapd/hostapd_%.bbappend34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-connectivity/hostapd/hostapd_%.bbappend b/recipes-connectivity/hostapd/hostapd_%.bbappend
index d94e2ad..7851129 100644
--- a/recipes-connectivity/hostapd/hostapd_%.bbappend
+++ b/recipes-connectivity/hostapd/hostapd_%.bbappend
@@ -4,3 +4,37 @@ do_install_append() {
install -d ${D}{sysconfdir}/modprobe.d
install -m 644 -D ${WORKDIR}/cfg80211.conf ${D}${sysconfdir}/modprobe.d/cfg80211.conf
}
+
+
+# -p option is striplevel
+SRC_URI += " file://cfg80211.conf \
+ file://WiFi-SSID \
+ file://setchan \
+ "
+
+do_install() {
+ install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir}
+ install -m 0755 ${S}/hostapd ${D}${sbindir}
+ install -m 0755 ${S}/hostapd_cli ${D}${sbindir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
+
+ install -m 644 -D ${WORKDIR}/cfg80211.conf ${D}${sysconfdir}/modprobe.d/cfg80211.conf
+ install -d ${D}/usr/share/hostap-daemon
+ install -m 0444 ${WORKDIR}/WiFi-SSID ${D}/usr/share/hostap-daemon/WiFi-SSID.patch
+ install -d ${D}/usr/local/bin
+ install -m 0744 ${WORKDIR}/setchan ${D}/usr/local/bin
+}
+
+PACKAGES =+ "${PN}-extra"
+FILES_${PN}-extra = "/usr/local/bin/* /usr/share/hostap-daemon/WiFi-SSID.patch"
+
+pkg_postinst_${PN}-bt-name() {
+ cd /$D
+ patch -Np1 < $D/usr/share/hostap-daemon/WiFi-SSID.patch
+}
+
+pkg_prerm_${PN}-bt-name() {
+ cd /$D
+ patch -Rp1 < $D/usr/share/hostap-daemon/WiFi-SSID.patch
+} \ No newline at end of file