summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-10-17 17:28:22 -0500
committerJohn Klug <john.klug@multitech.com>2017-10-17 17:28:22 -0500
commit12837c8670d2b876e1dc9e09d077ca9fc77c3bb4 (patch)
tree8e8df9f9ff21e62a120e35569afd39b755073e71
parentac8c734a41a12f01d4b6c0b284d9dd20ef13f8dc (diff)
downloadmeta-mlinux-12837c8670d2b876e1dc9e09d077ca9fc77c3bb4.tar.gz
meta-mlinux-12837c8670d2b876e1dc9e09d077ca9fc77c3bb4.tar.bz2
meta-mlinux-12837c8670d2b876e1dc9e09d077ca9fc77c3bb4.zip
Add pand related comments to /etc/network/interfaces
-rw-r--r--recipes-connectivity/bluez/bluez5_5.47.bb (renamed from recipes-connectivity/bluez/bluez5_5.46.bb)0
-rw-r--r--recipes-core/multitech/config/network/interfaces30
2 files changed, 24 insertions, 6 deletions
diff --git a/recipes-connectivity/bluez/bluez5_5.46.bb b/recipes-connectivity/bluez/bluez5_5.47.bb
index 9824aeb..9824aeb 100644
--- a/recipes-connectivity/bluez/bluez5_5.46.bb
+++ b/recipes-connectivity/bluez/bluez5_5.47.bb
diff --git a/recipes-core/multitech/config/network/interfaces b/recipes-core/multitech/config/network/interfaces
index 579c567..67c934b 100644
--- a/recipes-core/multitech/config/network/interfaces
+++ b/recipes-core/multitech/config/network/interfaces
@@ -9,6 +9,13 @@ auto eth0
iface eth0 inet static
address 192.168.2.1
netmask 255.255.255.0
+# Forwarding packets on eth0
+# gateway 192.168.2.2
+# pre-up bash -c 'echo 1 >/proc/sys/net/ipv4/ip_forward'
+# post-up iptables -F
+# post-up iptables -t nat -F
+# post-up iptables -t mangle -F
+# post-up iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
# Bridge interface with eth0 (comment out eth0 lines above to use with bridge)
# iface eth0 inet manual
@@ -55,9 +62,20 @@ netmask 255.255.255.0
#
# See https://busybox.net/downloads/BusyBox.html for more information.
#
-#auto wifi0
-#iface wifi0 inet dhcp
-#wpa-conf /etc/wpa_supplicant.conf
-#wpa-driver nl80211
-#pre-up bash -c '([[ -d /sys/class/net/wifi0 ]] || /opt/rs9113/onebox_util rpine0 create_vap wifi0 sta sw_bmiss)'
-#udhcpc_opts -t 10 -b
+# auto wifi0
+# iface wifi0 inet dhcp
+# wpa-conf /etc/wpa_supplicant.conf
+# wpa-driver nl80211
+# pre-up bash -c '([[ -d /sys/class/net/wifi0 ]] || /opt/rs9113/onebox_util rpine0 create_vap wifi0 sta sw_bmiss)'
+# udhcpc_opts -t 10 -b
+
+# The pan0 interface purpose is to support bluetooth pand
+# If access to another network is required, the ip forwarding
+# for eth0 could be enabled.
+# auto pan0
+# iface pan0 inet static
+# address 10.1.0.1
+# netmask 255.255.255.0
+# pre-up brctl addbr pan0
+# pre-up brctl setfd pan0 0
+# pre-up brctl stp pan0 off