From 96320445e357ac45549074f6ec8c39c965e581bb Mon Sep 17 00:00:00 2001
From: Saul Wold <sgw@linux.intel.com>
Date: Fri, 22 May 2015 08:26:46 -0700
Subject: boost/bjam-native: Upgrade to 1.58.0

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 meta/recipes-support/boost/bjam-native_1.57.0.bb | 15 ---------------
 meta/recipes-support/boost/bjam-native_1.58.0.bb | 15 +++++++++++++++
 meta/recipes-support/boost/boost-1.57.0.inc      | 19 -------------------
 meta/recipes-support/boost/boost-1.58.0.inc      | 19 +++++++++++++++++++
 meta/recipes-support/boost/boost_1.57.0.bb       |  6 ------
 meta/recipes-support/boost/boost_1.58.0.bb       |  6 ++++++
 6 files changed, 40 insertions(+), 40 deletions(-)
 delete mode 100644 meta/recipes-support/boost/bjam-native_1.57.0.bb
 create mode 100644 meta/recipes-support/boost/bjam-native_1.58.0.bb
 delete mode 100644 meta/recipes-support/boost/boost-1.57.0.inc
 create mode 100644 meta/recipes-support/boost/boost-1.58.0.inc
 delete mode 100644 meta/recipes-support/boost/boost_1.57.0.bb
 create mode 100644 meta/recipes-support/boost/boost_1.58.0.bb

(limited to 'meta')

diff --git a/meta/recipes-support/boost/bjam-native_1.57.0.bb b/meta/recipes-support/boost/bjam-native_1.57.0.bb
deleted file mode 100644
index d85d1a96cb..0000000000
--- a/meta/recipes-support/boost/bjam-native_1.57.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-include boost-${PV}.inc
-
-SUMMARY = "Portable Boost.Jam build tool for boost"
-SECTION = "devel"
-
-inherit native
-
-do_compile() {
-    ./bootstrap.sh --with-toolset=gcc
-}
-
-do_install() {
-    install -d ${D}${bindir}/
-    install -c -m 755 bjam ${D}${bindir}/
-}
diff --git a/meta/recipes-support/boost/bjam-native_1.58.0.bb b/meta/recipes-support/boost/bjam-native_1.58.0.bb
new file mode 100644
index 0000000000..d85d1a96cb
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.58.0.bb
@@ -0,0 +1,15 @@
+include boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+do_compile() {
+    ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+    install -d ${D}${bindir}/
+    install -c -m 755 bjam ${D}${bindir}/
+}
diff --git a/meta/recipes-support/boost/boost-1.57.0.inc b/meta/recipes-support/boost/boost-1.57.0.inc
deleted file mode 100644
index 809419dbac..0000000000
--- a/meta/recipes-support/boost/boost-1.57.0.inc
+++ /dev/null
@@ -1,19 +0,0 @@
-# The Boost web site provides free peer-reviewed portable
-# C++ source libraries. The emphasis is on libraries which
-# work well with the C++ Standard Library. The libraries are
-# intended to be widely useful, and are in regular use by
-# thousands of programmers across a broad spectrum of applications.
-HOMEPAGE = "http://www.boost.org/"
-LICENSE = "BSL-1.0 & MIT & Python-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
-
-BOOST_VER = "${@"_".join(d.getVar("PV",1).split("."))}"
-BOOST_MAJ = "${@"_".join(d.getVar("PV",1).split(".")[0:2])}"
-BOOST_P = "boost_${BOOST_VER}"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
-
-SRC_URI[md5sum] = "1be49befbdd9a5ce9def2983ba3e7b76"
-SRC_URI[sha256sum] = "910c8c022a33ccec7f088bd65d4f14b466588dda94ba2124e78b8c57db264967"
-
-S = "${WORKDIR}/${BOOST_P}"
diff --git a/meta/recipes-support/boost/boost-1.58.0.inc b/meta/recipes-support/boost/boost-1.58.0.inc
new file mode 100644
index 0000000000..0bae81bcfa
--- /dev/null
+++ b/meta/recipes-support/boost/boost-1.58.0.inc
@@ -0,0 +1,19 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+HOMEPAGE = "http://www.boost.org/"
+LICENSE = "BSL-1.0 & MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+BOOST_VER = "${@"_".join(d.getVar("PV",1).split("."))}"
+BOOST_MAJ = "${@"_".join(d.getVar("PV",1).split(".")[0:2])}"
+BOOST_P = "boost_${BOOST_VER}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
+
+SRC_URI[md5sum] = "b8839650e61e9c1c0a89f371dd475546"
+SRC_URI[sha256sum] = "fdfc204fc33ec79c99b9a74944c3e54bd78be4f7f15e260c0e2700a36dc7d3e5"
+
+S = "${WORKDIR}/${BOOST_P}"
diff --git a/meta/recipes-support/boost/boost_1.57.0.bb b/meta/recipes-support/boost/boost_1.57.0.bb
deleted file mode 100644
index c09d5f431f..0000000000
--- a/meta/recipes-support/boost/boost_1.57.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-include boost-${PV}.inc
-include boost.inc
-
-SRC_URI += "\
-    file://arm-intrinsics.patch \
-"
diff --git a/meta/recipes-support/boost/boost_1.58.0.bb b/meta/recipes-support/boost/boost_1.58.0.bb
new file mode 100644
index 0000000000..c09d5f431f
--- /dev/null
+++ b/meta/recipes-support/boost/boost_1.58.0.bb
@@ -0,0 +1,6 @@
+include boost-${PV}.inc
+include boost.inc
+
+SRC_URI += "\
+    file://arm-intrinsics.patch \
+"
-- 
cgit v1.2.3