From 1bb2c58ef7de3a1d52b4a29ca3cc230defe6c21d Mon Sep 17 00:00:00 2001
From: Li Zhou
Date: Thu, 30 Apr 2015 17:34:23 +0800
Subject: boost/libxslt: Enable nativesdk to unbreak
When run , the make will be broken because
nativesdk-boost and nativesdk-libxslt don't exist.
nativesdk-boost is depended by nativesdk-curlpp.
nativesdk-libxslt is depended by nativesdk-python-lxml.
In condition that meta-openembedded is compiled in.
Add nativesdk building for boost and libxslt.
Signed-off-by: Li Zhou
Signed-off-by: Richard Purdie
---
meta/recipes-support/boost/boost.inc | 2 +-
meta/recipes-support/libxslt/libxslt_1.1.28.bb | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
(limited to 'meta')
diff --git a/meta/recipes-support/boost/boost.inc b/meta/recipes-support/boost/boost.inc
index 6b42133aed..7628e37d6f 100644
--- a/meta/recipes-support/boost/boost.inc
+++ b/meta/recipes-support/boost/boost.inc
@@ -181,4 +181,4 @@ do_install() {
}
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.28.bb b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
index ded883e457..166bcd86e7 100644
--- a/meta/recipes-support/libxslt/libxslt_1.1.28.bb
+++ b/meta/recipes-support/libxslt/libxslt_1.1.28.bb
@@ -43,4 +43,4 @@ do_install_append_class-native () {
FILES_${PN} += "${libdir}/libxslt-plugins"
FILES_${PN}-dev += "${libdir}/xsltConf.sh"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
--
cgit v1.2.3