From 424dcf7046e4ad09dcc664eb1992201195247fcf Mon Sep 17 00:00:00 2001
From: Paul Eggleton <paul.eggleton@linux.intel.com>
Date: Wed, 29 Aug 2012 11:38:34 +0100
Subject: Rename task to packagegroup

"Package group" is a much more appropriate name for these than task,
since we use the word task to describe units of work executed by
BitBake.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 .../packagegroup-core-gtk-directfb.bb              | 26 ++++++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb

(limited to 'meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb')

diff --git a/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb b/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb
new file mode 100644
index 0000000000..8609013e9e
--- /dev/null
+++ b/meta/recipes-graphics/packagegroups/packagegroup-core-gtk-directfb.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "gkt+ over directfb without x11"
+PR = "r0"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+inherit packagegroup
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+PACKAGES += " \
+	${PN}-base \
+"
+
+RDEPENDS_${PN}-base = " \
+		directfb \
+		directfb-examples \
+		pango \
+		pango-modules \
+		fontconfig \
+		gtk+ \
+		gtk-demo \
+		dropbear \
+		${TOUCH} \
+"
-- 
cgit v1.2.3