From 1d8c40d5f2119b4c4ae8a9b2645ae572ea9a54ff Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard.purdie@linuxfoundation.org>
Date: Mon, 16 Apr 2012 10:47:56 +0100
Subject: python: Fix re-execution problem due to patching configure and
 configure.in

There was a patch patching both configure and configure.in. Since the recipes
all autoreconf, this is pointless and means subsequent patch tasks fail.

The fix is to only patch configure.in.

[YOCTO #2194]

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../python-native/sys_platform_is_now_always_linux2.patch     | 11 -----------
 1 file changed, 11 deletions(-)

(limited to 'meta/recipes-devtools/python/python-native')

diff --git a/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch b/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
index ed529366c5..1cb8fea50f 100644
--- a/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
+++ b/meta/recipes-devtools/python/python-native/sys_platform_is_now_always_linux2.patch
@@ -14,17 +14,6 @@ Issue #12326: sys.platform is now always 'linux2' on Linux
 
 Even if Python is compiled on Linux 3.
 
-diff --git a/configure b/configure
---- a/configure
-+++ b/configure
-@@ -2995,6 +2995,7 @@ then
- 	MACHDEP="$ac_md_system$ac_md_release"
- 
- 	case $MACHDEP in
-+	linux*) MACHDEP="linux2";;
- 	cygwin*) MACHDEP="cygwin";;
- 	darwin*) MACHDEP="darwin";;
- 	atheos*) MACHDEP="atheos";;
 diff --git a/configure.in b/configure.in
 --- a/configure.in
 +++ b/configure.in
-- 
cgit v1.2.3