From fc59d35a8ceae6302e0a161bab04829fdfd157cd Mon Sep 17 00:00:00 2001
From: Kristian Amlie <kristian.amlie@mender.io>
Date: Mon, 30 Jan 2017 16:43:38 +0100
Subject: wic-tools: Do not remove sysroot with rm_work, because wic needs it.

The sysroot of wic-tools is needed for wic, but if rm_work is enabled,
it will be removed before wic has a chance to use it, hence this fix.

Signed-off-by: Kristian Amlie <kristian.amlie@mender.io>
Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 meta/recipes-core/meta/wic-tools.bb | 4 ++++
 1 file changed, 4 insertions(+)

(limited to 'meta/recipes-core')

diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
index 1d9ea9c0e9..bd4319a803 100644
--- a/meta/recipes-core/meta/wic-tools.bb
+++ b/meta/recipes-core/meta/wic-tools.bb
@@ -9,6 +9,10 @@ DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
 INHIBIT_DEFAULT_DEPS = "1"
 inherit nopackages
 
+# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
+# be removed before wic has a chance to use it, hence the exclusion below.
+RM_WORK_EXCLUDE += "${PN}"
+
 python do_build_sysroot () {
     bb.build.exec_func("extend_recipe_sysroot", d)
 
-- 
cgit v1.2.3