From bda8282653b87fe5a8b485f8b628ab80797579f6 Mon Sep 17 00:00:00 2001
From: Enric Balletbo i Serra <eballetbo@iseebcn.com>
Date: Mon, 1 Mar 2010 11:44:25 +0100
Subject: gcc: Fix fail to compile since they can't find limits.h include.

With gcc package on my build machine gcc can't find limits.h include.

$ cat x.c

$ gcc -M x.c
In file included from x.c:1:
/usr/include/limits.h:125:26: error: no include path in which to search for limits.h

This patch adds missing includes to gcc package.

Signed-off-by: Enric Balletbo i Serra <eballetbo@iseebcn.com>
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
---
 meta/packages/gcc/gcc-cross_4.3.3.bb     | 2 +-
 meta/packages/gcc/gcc-package-target.inc | 1 +
 meta/packages/gcc/gcc_4.3.3.bb           | 2 +-
 3 files changed, 3 insertions(+), 2 deletions(-)

(limited to 'meta/packages')

diff --git a/meta/packages/gcc/gcc-cross_4.3.3.bb b/meta/packages/gcc/gcc-cross_4.3.3.bb
index 84bee6baf3..22efffa539 100644
--- a/meta/packages/gcc/gcc-cross_4.3.3.bb
+++ b/meta/packages/gcc/gcc-cross_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
 
 require gcc-${PV}.inc
 require gcc-cross4.inc
diff --git a/meta/packages/gcc/gcc-package-target.inc b/meta/packages/gcc/gcc-package-target.inc
index 989822bd6e..c1200b8bc7 100644
--- a/meta/packages/gcc/gcc-package-target.inc
+++ b/meta/packages/gcc/gcc-package-target.inc
@@ -21,6 +21,7 @@ FILES_${PN} = "\
   ${gcclibdir}/${TARGET_SYS}/${BINV}/specs \
   ${gcclibdir}/${TARGET_SYS}/${BINV}/lib* \
   ${gcclibdir}/${TARGET_SYS}/${BINV}/include \
+  ${gcclibdir}/${TARGET_SYS}/${BINV}/include-fixed \
 "
 FILES_${PN}-symlinks = "\
   ${bindir}/cc \
diff --git a/meta/packages/gcc/gcc_4.3.3.bb b/meta/packages/gcc/gcc_4.3.3.bb
index c51d537d2d..7238aed4d7 100644
--- a/meta/packages/gcc/gcc_4.3.3.bb
+++ b/meta/packages/gcc/gcc_4.3.3.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
 
 require gcc-${PV}.inc
 require gcc-configure-target.inc
-- 
cgit v1.2.3