From 66aa9f1424202a583acd168182ae13ea68e2ab15 Mon Sep 17 00:00:00 2001
From: Li Wang
Date: Fri, 25 May 2018 10:48:13 +0800
Subject: gawk: fix command location in ptest script
* Correct the command location in ptest scripts such as
update the line "#!/bin/awk -f" to "#!/usr/bin/awk -f" in the
file /usr/lib64/gawk/ptest/test/fcall_exit2.awk belongs
to package gawk-ptest and the line "#!/usr/local/bin/gawk -f"
to "#!/usr/bin/gawk -f" in the file
/usr/lib64/gawk/ptest/test/fnarydel.awk
Signed-off-by: Li Wang
Signed-off-by: Mingli Yu
Signed-off-by: Richard Purdie
---
meta/recipes-extended/gawk/gawk_4.2.1.bb | 2 ++
1 file changed, 2 insertions(+)
diff --git a/meta/recipes-extended/gawk/gawk_4.2.1.bb b/meta/recipes-extended/gawk/gawk_4.2.1.bb
index 6b9935767b..9663752394 100644
--- a/meta/recipes-extended/gawk/gawk_4.2.1.bb
+++ b/meta/recipes-extended/gawk/gawk_4.2.1.bb
@@ -43,6 +43,8 @@ do_install_ptest() {
for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests inclib.awk; \
do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
done
+ sed -i -e 's|/usr/local/bin|${bindir}|g' \
+ -e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk
}
BBCLASSEXTEND = "native nativesdk"
--
cgit v1.2.3