From 5191ab6962712908e1aa1dca0d4253fb278366c2 Mon Sep 17 00:00:00 2001
From: Richard Purdie <richard.purdie@linuxfoundation.org>
Date: Mon, 3 Aug 2015 17:47:31 +0100
Subject: weston: Fix parallel make race

The current approach used by the Makefile ends up installing
weston.desktop twice and can give build failures when using
parallel make flags. Change to just have one DATA reference.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../wayland/weston/parallelmake.patch              | 22 ++++++++++++++++++++++
 meta/recipes-graphics/wayland/weston_1.8.0.bb      |  1 +
 2 files changed, 23 insertions(+)
 create mode 100644 meta/recipes-graphics/wayland/weston/parallelmake.patch

diff --git a/meta/recipes-graphics/wayland/weston/parallelmake.patch b/meta/recipes-graphics/wayland/weston/parallelmake.patch
new file mode 100644
index 0000000000..34d7512b9e
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston/parallelmake.patch
@@ -0,0 +1,22 @@
+The current approach used by the Makefile ends up installing 
+weston.desktop twice and can give build failures when using 
+parallel make flags. Change to just have one DATA reference.
+
+RP
+2015/8/3
+Upstream-Status: Pending
+
+Index: weston-1.8.0/Makefile.am
+===================================================================
+--- weston-1.8.0.orig/Makefile.am
++++ weston-1.8.0/Makefile.am
+@@ -179,8 +179,7 @@ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = src/weston.pc
+ 
+ wayland_sessiondir = $(datadir)/wayland-sessions
+-wayland_session_DATA = src/weston.desktop
+-dist_wayland_session_DATA = $(wayland_session_DATA)
++dist_wayland_session_DATA = src/weston.desktop
+ 
+ westonincludedir = $(includedir)/weston
+ westoninclude_HEADERS =				\
diff --git a/meta/recipes-graphics/wayland/weston_1.8.0.bb b/meta/recipes-graphics/wayland/weston_1.8.0.bb
index ac6bd9784b..342c604b98 100644
--- a/meta/recipes-graphics/wayland/weston_1.8.0.bb
+++ b/meta/recipes-graphics/wayland/weston_1.8.0.bb
@@ -11,6 +11,7 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
            file://make-lcms-explicitly-configurable.patch \
            file://make-libwebp-explicitly-configurable.patch \
            file://0001-make-error-portable.patch \
+           file://parallelmake.patch \
 "
 SRC_URI[md5sum] = "24cb8a7ed0535b4fc3642643988dab36"
 SRC_URI[sha256sum] = "8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312"
-- 
cgit v1.2.3