summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/devtool/build-image.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/scripts/lib/devtool/build-image.py b/scripts/lib/devtool/build-image.py
index 563563b3e7..5bc82134c1 100644
--- a/scripts/lib/devtool/build-image.py
+++ b/scripts/lib/devtool/build-image.py
@@ -50,6 +50,11 @@ def build_image(args, config, basepath, workspace):
appendfile = os.path.join(config.workspace_path, 'appends',
'%s.bbappend' % image)
+ # remove <image>.bbapend to make sure setup_tinfoil doesn't
+ # breake because of it
+ if os.path.isfile(appendfile):
+ os.unlink(appendfile)
+
recipes = _get_recipes(workspace, config)
if recipes:
with open(appendfile, 'w') as afile: