summaryrefslogtreecommitdiff
path: root/openembedded/packages/gcc
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/gcc')
-rw-r--r--openembedded/packages/gcc/gcc-package-cross.inc2
-rw-r--r--openembedded/packages/gcc/gcc3-build.inc5
-rw-r--r--openembedded/packages/gcc/gcc_4.0.2.bb2
3 files changed, 5 insertions, 4 deletions
diff --git a/openembedded/packages/gcc/gcc-package-cross.inc b/openembedded/packages/gcc/gcc-package-cross.inc
index 56299b5157..4b1f8f68e8 100644
--- a/openembedded/packages/gcc/gcc-package-cross.inc
+++ b/openembedded/packages/gcc/gcc-package-cross.inc
@@ -72,6 +72,6 @@ do_install () {
if [ "x${OLD_INHIBIT_PACKAGE_STRIP}" != "x1" ]; then
${TARGET_PREFIX}strip ${D}${target_libdir}/libstdc++.so.*
${TARGET_PREFIX}strip ${D}${target_libdir}/libg2c.so.*
- ${TARGET_PREFIX}strip ${D}${base_libdir}/libgcc_s.so.*
+ ${TARGET_PREFIX}strip ${D}${target_base_libdir}/libgcc_s.so.*
fi
}
diff --git a/openembedded/packages/gcc/gcc3-build.inc b/openembedded/packages/gcc/gcc3-build.inc
index a09c6cf1f5..b7523c42f2 100644
--- a/openembedded/packages/gcc/gcc3-build.inc
+++ b/openembedded/packages/gcc/gcc3-build.inc
@@ -47,7 +47,10 @@ CPPFLAGS = ""
# Used by configure to define additional values for FLAGS_FOR_TARGET -
# passed to all the compilers.
ARCH_FLAGS_FOR_TARGET = ""
-ARCH_FLAGS_FOR_TARGET_nslu2 = "${TARGET_CC_ARCH}"
+#NOTE: not tested on other platforms, the following is probably correct
+# everywhere!
+ARCH_FLAGS_FOR_TARGET_slugos = "${TARGET_CC_ARCH}"
+ARCH_FLAGS_FOR_TARGET_unslung = "${TARGET_CC_ARCH}"
EXTRA_OEMAKE += "ARCH_FLAGS_FOR_TARGET='${ARCH_FLAGS_FOR_TARGET}'"
def get_gcc_fpu_setting(bb, d):
diff --git a/openembedded/packages/gcc/gcc_4.0.2.bb b/openembedded/packages/gcc/gcc_4.0.2.bb
index 856809a7bb..ba64d2421a 100644
--- a/openembedded/packages/gcc/gcc_4.0.2.bb
+++ b/openembedded/packages/gcc/gcc_4.0.2.bb
@@ -5,8 +5,6 @@ SECTION = "devel"
LICENSE = "GPL"
MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
-DEFAULT_PREFERENCE_nslu2 = "-1"
-
inherit autotools gettext
include gcc-package.inc