summaryrefslogtreecommitdiff
path: root/meta/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb4
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 3a323e7e15..1729c78a20 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -106,10 +106,10 @@ do_archgen () {
continue;;
esac
if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then
- echo -n " const Arch Arch_${each_arch} " | tr - _ >> zypp/oe-arch.h
+ printf " const Arch Arch_${each_arch} " | tr - _ >> zypp/oe-arch.h
echo "(_${each_arch});" | tr - _ >> zypp/oe-arch.h
else
- echo -n " const Arch Arch_${each_arch} " | tr - _ >> zypp/oe-arch.h
+ printf " const Arch Arch_${each_arch} " | tr - _ >> zypp/oe-arch.h
echo "( IdString ( \"${each_arch}\" ) );" | tr - _ >> zypp/oe-arch.h
fi
done
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index a3242db708..55ea241783 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -31,12 +31,12 @@ do_install(){
mkdir -p ${D}${base_bindir}
mkdir -p ${D}/${baselib}
mkdir -p ${D}${sysconfdir}/lsb-release.d
- echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
+ printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
if [ "${TARGET_ARCH}" = "i586" ];then
- echo -n "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
+ printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
else
- echo -n "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
+ printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
fi
echo "\"" >> ${D}${sysconfdir}/lsb-release
echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release