summaryrefslogtreecommitdiff
path: root/meta/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb6
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run7
2 files changed, 1 insertions, 12 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
index ac3e7f3dad..6775af34e3 100644
--- a/meta/recipes-bsp/qemu-config/qemu-config.bb
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -10,7 +10,6 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemumips|qemuppc)"
PR = "r25"
SRC_URI = "file://distcc.sh \
- file://anjuta-remote-run \
file://exports \
file://shutdown.desktop \
file://qemu-autostart"
@@ -23,9 +22,6 @@ do_install() {
install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
install -m 0644 exports ${D}${sysconfdir}/
- install -d ${D}${bindir}
- install -m 0755 anjuta-remote-run ${D}${bindir}/
-
install -d ${D}${datadir}/applications
install -m 0644 shutdown.desktop ${D}${datadir}/applications/
@@ -38,7 +34,7 @@ pkg_postinst_${PN} () {
sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
}
-RDEPENDS_${PN} = "distcc ${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)} packagegroup-core-nfs-server oprofileui-server rsync bash"
+RDEPENDS_${PN} = "distcc packagegroup-core-nfs-server oprofileui-server bash"
inherit update-rc.d allarch
diff --git a/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run b/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run
deleted file mode 100644
index 620e3a705b..0000000000
--- a/meta/recipes-bsp/qemu-config/qemu-config/anjuta-remote-run
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-. /etc/profile
-export DISPLAY=:0
-dbus-launch $@
-
-