summaryrefslogtreecommitdiff
path: root/meta/packages/zeroconf
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/zeroconf')
-rw-r--r--meta/packages/zeroconf/zeroconf/compilefix.patch17
-rw-r--r--meta/packages/zeroconf/zeroconf/debian-zeroconf51
-rw-r--r--meta/packages/zeroconf/zeroconf/zeroconf-default17
-rw-r--r--meta/packages/zeroconf/zeroconf_0.9.bb22
4 files changed, 0 insertions, 107 deletions
diff --git a/meta/packages/zeroconf/zeroconf/compilefix.patch b/meta/packages/zeroconf/zeroconf/compilefix.patch
deleted file mode 100644
index b7b917dc2b..0000000000
--- a/meta/packages/zeroconf/zeroconf/compilefix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-| zeroconf.c: In function 'main':
-| zeroconf.c:145: error: 'PATH_MAX' undeclared (first use in this function)
-
-RP - 4/9/09
-
-Index: zeroconf-0.9/zeroconf.c
-===================================================================
---- zeroconf-0.9.orig/zeroconf.c 2009-09-04 10:05:25.000000000 +0100
-+++ zeroconf-0.9/zeroconf.c 2009-09-04 10:05:42.000000000 +0100
-@@ -33,6 +33,7 @@
- #include <net/if_arp.h>
- #include <sys/time.h>
- #include <signal.h>
-+#include <limits.h>
-
- #include "delay.h"
-
diff --git a/meta/packages/zeroconf/zeroconf/debian-zeroconf b/meta/packages/zeroconf/zeroconf/debian-zeroconf
deleted file mode 100644
index c3705d2788..0000000000
--- a/meta/packages/zeroconf/zeroconf/debian-zeroconf
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/bin/sh
-
-if [ ! -x /usr/sbin/zeroconf ]; then
- exit 0
-fi
-
-# IPv4 link-local addresses (zeroconf) are
-# only applicable on the 'inet' address family
-[ "X$ADDRFAM" != "Xinet" ] && exit 0
-
-# However there are some methods where it doesn't
-# make any sense to configure an IPv4LL address
-
-# not on loopback
-[ "X$METHOD" = "Xloopback" ] && exit 0
-
-# not on ppp or wvdial either
-[ "X$METHOD" = "Xppp" ] && exit 0
-[ "X$METHOD" = "Xwvdial" ] && exit 0
-
-# The administrator may have blacklisted interfaces
-# or only want zeroconf in a fallback situation
-[ -f /etc/default/zeroconf ] &&
- . /etc/default/zeroconf
-
-[ -n "$DISABLE" ] && exit 0
-
-for BLACK in $IFBLACKLIST; do
- case $IFACE in
- $BLACK)
- exit 0
- ;;
- esac
-done
-
-# should we only allocate an address if we do not already have one?
-if [ -n "$FALLBACK" ]; then
- /bin/ip addr show $IFACE scope global | grep -q "inet"
- IP=$?
- if [ $IP -eq 0 ]; then
- /bin/ip route add 169.254.0.0/16 dev $IFACE
- exit 0
- fi
-fi
-
-# otherwise, run if we aren't already going
-if [ ! -r /var/run/zeroconf.$IFACE.pid ]; then
- /usr/sbin/zeroconf -i $IFACE
-fi
-
-exit 0
diff --git a/meta/packages/zeroconf/zeroconf/zeroconf-default b/meta/packages/zeroconf/zeroconf/zeroconf-default
deleted file mode 100644
index cc07b275f1..0000000000
--- a/meta/packages/zeroconf/zeroconf/zeroconf-default
+++ /dev/null
@@ -1,17 +0,0 @@
-# Default for zeroconf
-
-# disable zeroconf
-# If you want to disable zeroconf completely, uncomment the following line
-# this may be useful if you are debugging zeroconf or starting it manually
-#DISABLE=yes
-
-# black-listed interfaces
-# Interfaces which you never wish to have zeroconf run on should
-# be listed here. e.g. "eth2 wlan1" in a space seperated string
-IFBLACKLIST=""
-
-# fallback only
-# If you would only like a link-local address if you were unable to
-# obtain an address via DHCP then uncomment the following line
-#FALLBACK=yes
-
diff --git a/meta/packages/zeroconf/zeroconf_0.9.bb b/meta/packages/zeroconf/zeroconf_0.9.bb
deleted file mode 100644
index f22466eea7..0000000000
--- a/meta/packages/zeroconf/zeroconf_0.9.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "IPv4 link-local address allocator"
-AUTHOR = "Anand Kumria <wildfire@progsoc.uts.edu.au>"
-HOMEPAGE = "http://www.progsoc.org/~wildfire/zeroconf/"
-LICENSE = "GPL"
-SECTION = "net"
-PRIORITY = "optional"
-
-PR = "r1"
-
-SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${PN}-${PV}.tar.gz \
- file://compilefix.patch;patch=1 \
- file://zeroconf-default \
- file://debian-zeroconf"
-
-do_install () {
- install -d ${D}${sbindir}
- install -d ${D}${sysconfdir}/network/if-up.d
- install -d ${D}${sysconfdir}/default
- install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
- install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
- install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
-}