diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-09-18 18:09:54 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-09-18 19:49:30 +0100 |
commit | 82ad5305381c2f541ef051a8fc28243cd91776fe (patch) | |
tree | 912a43ac3512b35c0c476a0d3c52cf7fad48c4b8 /scripts/qemuimage-tests/systemusage | |
parent | b2cadab5c7a5d3f772c34c04b759823ed6a122bf (diff) | |
download | openembedded-core-82ad5305381c2f541ef051a8fc28243cd91776fe.tar.gz openembedded-core-82ad5305381c2f541ef051a8fc28243cd91776fe.tar.bz2 openembedded-core-82ad5305381c2f541ef051a8fc28243cd91776fe.zip |
linux-yocto/3.10: fix long perf compile times
perf's builtin-sched.c triggers extremly long build times on some
architectures due to gcc 4.7+ var-tracking functionality.
To fix this, we can cherry pick the 3.12 commit:
f36f83f94 [perf sched: Move struct perf_sched definition out of cmd_sched()]
With this change build times are reduced from 15 to 20 minutes for qemuarm to:
real 2m19.940s
user 1m35.438s
sys 0m11.165s
For kernel's that are not carrying this patch, the following can be added
to the perf recipe to also fix the issue:
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -68,6 +68,7 @@ EXTRA_OEMAKE = \
CC="${CC}" \
AR="${AR}" \
perfexecdir=${libexecdir} \
+ EXTRA_CFLAGS="-fno-var-tracking" \
NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${SCRIPTING_DEFINES} \
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/qemuimage-tests/systemusage')
0 files changed, 0 insertions, 0 deletions