summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/tzcode/tzcode-native_2016i.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-11-03 22:53:27 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-12-06 05:19:40 -0800
commit04de62b4edbe57310cd0b0857a7b0d08b885c38a (patch)
tree38f7fea2fda9b7b3d7a599b726af6fa5a05bfba4 /meta/recipes-extended/tzcode/tzcode-native_2016i.bb
parent1f1510e054a1643e9ec9cea6bc96288f9802bfbb (diff)
downloadopenembedded-core-04de62b4edbe57310cd0b0857a7b0d08b885c38a.tar.gz
openembedded-core-04de62b4edbe57310cd0b0857a7b0d08b885c38a.tar.bz2
openembedded-core-04de62b4edbe57310cd0b0857a7b0d08b885c38a.zip
tzcode: update to 2016i
Changes to code The code should now be buildable on AmigaOS merely by setting the appropriate Makefile variables. (From a patch by Carsten Larsen.) (From OE-Core rev: d2b8c4ee535684f5d874082a7f76efbda1907ea5) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016i.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016i.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016i.bb b/meta/recipes-extended/tzcode/tzcode-native_2016i.bb
new file mode 100644
index 0000000000..af55668672
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016i.bb
@@ -0,0 +1,25 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ef1a352b901ee7b75a75df8171d6aca7"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "8fae14cba9396462955b7859cf04ba48"
+SRC_URI[tzcode.sha256sum] = "411e8adcb6288b17d6c2624fde65e7d82654ca69b813ae121504ff66f0cfba7b"
+SRC_URI[tzdata.md5sum] = "73912ecfa6a9a8048ddf2e719d9bc39d"
+SRC_URI[tzdata.sha256sum] = "b6966ec982ef64fe48cebec437096b4f57f4287519ed32dde59c86d3a1853845"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}