summaryrefslogtreecommitdiff
path: root/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-23 12:10:22 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:08 +0000
commit431ad7a268fc07c367ce830c4f69dba515f44b4e (patch)
treecbdd5a19efcd1c947b001ec11ba3422a1257f4f7 /meta/recipes-extended/sudo/sudo_1.8.14p3.bb
parent705a369e5f48dc75f2db4ef814f63d11c2285058 (diff)
downloadopenembedded-core-431ad7a268fc07c367ce830c4f69dba515f44b4e.tar.gz
openembedded-core-431ad7a268fc07c367ce830c4f69dba515f44b4e.tar.bz2
openembedded-core-431ad7a268fc07c367ce830c4f69dba515f44b4e.zip
sudo: handle libexecdir != libdir/PN.
sudo has somewhat special file installation logic and installs the modules and libraries to $libexecdir/sudo, with special handling for the case when libexecdir already contains /sudo (which it does by default in current oe-core where libexecdir=$libdir/$PN). As setting libexecdir to /usr/libexec should work, add both possibilities to FILES to be sure the right files are captured, and add INSANE_SKIP for the libdir warning that libraries are outside of /usr/lib/ (arguably, this should be fixed in insane). Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/sudo/sudo_1.8.14p3.bb')
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.14p3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/sudo/sudo_1.8.14p3.bb b/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
index b93112fa3f..4db85e23f8 100644
--- a/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
+++ b/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
@@ -33,4 +33,5 @@ do_install_append () {
}
FILES_${PN} += "${libdir}/tmpfiles.d"
-FILES_${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/*.la"
+FILES_${PN}-dev += "${libexecdir}/${BPN}/lib*${SOLIBSDEV} ${libexecdir}/${BPN}/*.la \
+ ${libexecdir}/lib*${SOLIBSDEV} ${libexecdir}/*.la"