summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
diff options
context:
space:
mode:
authorGernot Hillier <gernot.hillier@siemens.com>2017-04-26 12:57:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-28 11:32:21 +0100
commitc93691b3d8b300d5cdeb1c9f1a052f7c32bba23b (patch)
tree18cb87df1be247f3f5d8c7a27fee6ff00b3937d6 /meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
parentabaaeeff07c88fb52a4fa70d33ed6c7946d086b2 (diff)
downloadopenembedded-core-c93691b3d8b300d5cdeb1c9f1a052f7c32bba23b.tar.gz
openembedded-core-c93691b3d8b300d5cdeb1c9f1a052f7c32bba23b.tar.bz2
openembedded-core-c93691b3d8b300d5cdeb1c9f1a052f7c32bba23b.zip
tcf-agent: fix machine setting for arm64 build
tcf-agent uses "a64", not "aarch64", see agent/Makefile.inc. This fix allows to re-enable features like SERVICE_Breakpoints and SERVICE_ MemoryMap on arm64. Signed-off-by: Gernot Hillier <gernot.hillier@siemens.com> Acked-by: Eugene Tarassov <eugene.tarassov@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcf-agent/tcf-agent_git.bb')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
index e5e41f148e..cd0081ac16 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -30,7 +30,7 @@ INITSCRIPT_NAME = "tcf-agent"
INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
# mangling needed for make
-MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686,`"
+MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64,a64,`"
MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"