summaryrefslogtreecommitdiff
path: root/meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2015-07-08 19:36:28 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-12 22:53:19 +0100
commite0cbd3c64dab5db5df6415bbc0042b1b50b3c7ac (patch)
treec7354360ae9c2a7c8771ca73000fba6fd6fe12c8 /meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1
parentc311d27f051f7b99c24dd5f19dbf0fc78948a3f1 (diff)
downloadopenembedded-core-e0cbd3c64dab5db5df6415bbc0042b1b50b3c7ac.tar.gz
openembedded-core-e0cbd3c64dab5db5df6415bbc0042b1b50b3c7ac.tar.bz2
openembedded-core-e0cbd3c64dab5db5df6415bbc0042b1b50b3c7ac.zip
i2c-tools: uprev to 3.1.2
The only changes based on the CHANGES file are: decode-dimms: Fix DDR3 extended temp range refresh rate decoding py-smbus: Add support for python 3 The python3 changes use python3 as the default and 2 as the fallback. py-smbus is not currently built so no python changes have been made. The local copy of Module.mk is unchanged aside from moving it to a directory that is not version specific to avoid uprev noise. Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1')
-rw-r--r--meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1/Module.mk72
1 files changed, 0 insertions, 72 deletions
diff --git a/meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1/Module.mk b/meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1/Module.mk
deleted file mode 100644
index fcaf72f22a..0000000000
--- a/meta/recipes-devtools/i2c-tools/i2c-tools-3.1.1/Module.mk
+++ /dev/null
@@ -1,72 +0,0 @@
-# EEPROMER
-#
-# Licensed under the GNU General Public License.
-
-EEPROMER_DIR := eepromer
-
-EEPROMER_CFLAGS := -Wstrict-prototypes -Wshadow -Wpointer-arith -Wcast-qual \
- -Wcast-align -Wwrite-strings -Wnested-externs -Winline \
- -W -Wundef -Wmissing-prototypes -Iinclude
-
-EEPROMER_TARGETS := eepromer eeprom eeprog
-
-#
-# Programs
-#
-
-$(EEPROMER_DIR)/eepromer: $(EEPROMER_DIR)/eepromer.o
- $(CC) $(LDFLAGS) -o $@ $^
-
-$(EEPROMER_DIR)/eeprom: $(EEPROMER_DIR)/eeprom.o
- $(CC) $(LDFLAGS) -o $@ $^
-
-$(EEPROMER_DIR)/eeprog: $(EEPROMER_DIR)/eeprog.o $(EEPROMER_DIR)/24cXX.o
- $(CC) $(LDFLAGS) -o $@ $^
-
-#
-# Objects
-#
-
-$(EEPROMER_DIR)/eepromer.o: $(EEPROMER_DIR)/eepromer.c
- $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@
-
-$(EEPROMER_DIR)/eeprom.o: $(EEPROMER_DIR)/eeprom.c
- $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@
-
-$(EEPROMER_DIR)/eeprog.o: $(EEPROMER_DIR)/eeprog.c
- $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@
-
-$(EEPROMER_DIR)/24cXX.o: $(EEPROMER_DIR)/24cXX.c
- $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@
-
-#
-# Commands
-#
-
-all-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS))
-
-strip-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS))
- strip $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS))
-
-clean-eepromer:
- $(RM) $(addprefix $(EEPROMER_DIR)/,*.o $(EEPROMER_TARGETS))
-
-install-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS))
- $(INSTALL_DIR) $(DESTDIR)$(sbindir) $(DESTDIR)$(man8dir)
- for program in $(EEPROMER_TARGETS) ; do \
- $(INSTALL_PROGRAM) $(EEPROMER_DIR)/$$program $(DESTDIR)$(sbindir) ; done
-
-uninstall-eepromer:
- for program in $(EEPROMER_TARGETS) ; do \
- $(RM) $(DESTDIR)$(sbindir)/$$program ; \
- $(RM) $(DESTDIR)$(man8dir)/$$program.8 ; done
-
-all: all-eepromer
-
-strip: strip-eepromer
-
-clean: clean-eepromer
-
-install: install-eepromer
-
-uninstall: uninstall-eepromer