summaryrefslogtreecommitdiff
path: root/meta/recipes-connectivity/socat/files
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-06 16:32:50 +0800
committerSaul Wold <sgw@linux.intel.com>2013-06-10 14:51:25 -0700
commitfa4d1526f639d50b578ff82b4e65ac45c612bcca (patch)
tree3db0ae1f4c2c42aaa85f22f1324df5fe022c6f86 /meta/recipes-connectivity/socat/files
parent4c6f7a5d8bd6ada434b91037ecd5db06f3eac814 (diff)
downloadopenembedded-core-fa4d1526f639d50b578ff82b4e65ac45c612bcca.tar.gz
openembedded-core-fa4d1526f639d50b578ff82b4e65ac45c612bcca.tar.bz2
openembedded-core-fa4d1526f639d50b578ff82b4e65ac45c612bcca.zip
socat: enable termios
fix two cross-compile issue to enable termios: 1. Define ac_cv_ispeed_offset in EXTRA_OECONF to avoid to call AC_TRY_RUN() on cross-compile environment. 2. fix autoheader to generate *_SHIFT macros Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-connectivity/socat/files')
-rw-r--r--meta/recipes-connectivity/socat/files/fix-xxx_SHIFT-autoheader.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/files/fix-xxx_SHIFT-autoheader.patch b/meta/recipes-connectivity/socat/files/fix-xxx_SHIFT-autoheader.patch
new file mode 100644
index 0000000000..44659a0b26
--- /dev/null
+++ b/meta/recipes-connectivity/socat/files/fix-xxx_SHIFT-autoheader.patch
@@ -0,0 +1,40 @@
+Subject: [PATCH] fix autoheader for *_SHIFT values.
+
+Upstream-Status: Pending
+
+autoheader would not generate C `#define' statements if
+the first param of AC_DEFINE_UNQUOTED is a shell variable.
+This will cause build failures while enable termios, so
+expand these AC_DEFINE_UNQUOTED from the macro.
+
+Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com>
+---
+ configure.in | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index c54e4c4..13bae64 100644
+--- a/configure.in
++++ b/configure.in
+@@ -1335,8 +1335,6 @@ AC_CACHE_CHECK(shift offset of $1, $2,
+ [$2=-1]
+ )
+ LIBS="$LIBS1"])
+-SHIFT_NAME="$1"_SHIFT
+-AC_DEFINE_UNQUOTED($SHIFT_NAME, ${$2}, [foo])
+ if test "$2" = -1; then
+ AC_MSG_WARN(please determine $1_SHIFT manually)
+ fi
+@@ -1346,6 +1344,9 @@ AC_SHIFT_OFFSET(CRDLY, sc_cv_sys_crdly_shift)
+ AC_SHIFT_OFFSET(TABDLY, sc_cv_sys_tabdly_shift)
+ AC_SHIFT_OFFSET(CSIZE, sc_cv_sys_csize_shift)
+
++AC_DEFINE_UNQUOTED(CRDLY_SHIFT, ${sc_cv_sys_crdly_shift}, [shift for CRDLY, carriage return delay])
++AC_DEFINE_UNQUOTED(TABDLY_SHIFT, ${sc_cv_sys_tabdly_shift}, [shift for TABDLY, horizontal tab delay])
++AC_DEFINE_UNQUOTED(CSIZE_SHIFT, ${sc_cv_sys_csize_shift}, [shift for CSIZE, character size])
+
+ dnl find what physical type (basic C type) is equivalent to the given type.
+ dnl arg1: include file(s)
+--
+1.7.9.5
+