summaryrefslogtreecommitdiff
path: root/meta/packages/tasks/task-sdk-host.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-09-01 22:49:32 +0000
committerRichard Purdie <richard@openedhand.com>2007-09-01 22:49:32 +0000
commitf19cf866982d04bbde0a007fca07ed5db66e3898 (patch)
tree6eaf0af43b7b232583c965eda7672ff64f451a25 /meta/packages/tasks/task-sdk-host.bb
parentc6938aad87ce4b9ce25ecd020ecddfe62b319bcf (diff)
downloadopenembedded-core-f19cf866982d04bbde0a007fca07ed5db66e3898.tar.gz
openembedded-core-f19cf866982d04bbde0a007fca07ed5db66e3898.tar.bz2
openembedded-core-f19cf866982d04bbde0a007fca07ed5db66e3898.zip
meta-toolchain: Change to be more generic and use package_ipk conf generation functions. Also rename task-poky-standalone-sdk-host to task-sdk-host and add copyright.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2638 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/tasks/task-sdk-host.bb')
-rw-r--r--meta/packages/tasks/task-sdk-host.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/packages/tasks/task-sdk-host.bb b/meta/packages/tasks/task-sdk-host.bb
new file mode 100644
index 0000000000..d238b46144
--- /dev/null
+++ b/meta/packages/tasks/task-sdk-host.bb
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd
+#
+
+DESCRIPTION = "Host packages for the standalone SDK or external toolchain"
+PR = "r1"
+LICENSE = "MIT"
+ALLOW_EMPTY = "1"
+
+inherit sdk
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} = "\
+ binutils-cross-sdk \
+ gcc-cross-sdk \
+ gdb-cross-sdk \
+ g++ \
+ cpp \
+ libgcc \
+ libgcc-dev \
+ libstdc++ \
+ libstdc++-dev \
+ "