summaryrefslogtreecommitdiff
path: root/meta/packages/mozilla/minimo
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/mozilla/minimo
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadopenembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.bz2
openembedded-core-b2f192faabe412adce79534e22efe9fb69ee40e2.zip
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/mozilla/minimo')
-rw-r--r--meta/packages/mozilla/minimo/host_ldflags_fix.patch62
-rw-r--r--meta/packages/mozilla/minimo/mozconfig76
2 files changed, 138 insertions, 0 deletions
diff --git a/meta/packages/mozilla/minimo/host_ldflags_fix.patch b/meta/packages/mozilla/minimo/host_ldflags_fix.patch
new file mode 100644
index 0000000000..888f545e9d
--- /dev/null
+++ b/meta/packages/mozilla/minimo/host_ldflags_fix.patch
@@ -0,0 +1,62 @@
+Index: mozilla/nsprpub/config/rules.mk
+===================================================================
+--- mozilla.orig/nsprpub/config/rules.mk 2005-01-04 21:27:36.000000000 +0000
++++ mozilla/nsprpub/config/rules.mk 2005-09-30 11:27:33.000000000 +0000
+@@ -87,6 +87,9 @@
+ CCC=$(HOST_CXX)
+ CFLAGS=$(HOST_CFLAGS)
+ CXXFLAGS=$(HOST_CXXFLAGS)
++LDFLAGS=$(HOST_LDFLAGS)
++RANLIB=$(HOST_RANLIB)
++AR=$(HOST_AR)
+ endif
+ endif
+ endif
+Index: mozilla/configure.in
+===================================================================
+--- mozilla.orig/configure.in 2005-03-30 17:57:38.000000000 +0000
++++ mozilla/configure.in 2005-09-30 11:36:44.000000000 +0000
+@@ -5612,13 +5612,18 @@
+ fi
+
+ if test -n "$CROSS_COMPILE"; then
+- if test -z "$HOST_LIBIDL_CONFIG"; then
++ if test -z "$HOST_LIBIDL_CONFIG"; then
++ AC_MSG_WARN([HOST_LIBIDL_CONFIG not defined])
+ HOST_LIBIDL_CONFIG="$LIBIDL_CONFIG"
+ fi
+ if test -n "$HOST_LIBIDL_CONFIG"; then
++ AC_MSG_WARN([using $HOST_LIBIDL_CONFIG as config for libIDL on host])
+ HOST_LIBIDL_CFLAGS=`${HOST_LIBIDL_CONFIG} --cflags`
++ AC_MSG_WARN([HOST_LIBIDL_CFLAGS=$HOST_LIBIDL_CFLAGS])
+ HOST_LIBIDL_LIBS=`${HOST_LIBIDL_CONFIG} --libs`
++ AC_MSG_WARN([HOST_LIBIDL_LIBS=$HOST_LIBIDL_LIBS])
+ else
++ AC_MSG_WARN([no config for libIDL found, using LIBIDL_CFLAGS and LIBIDL_LIBS])
+ HOST_LIBIDL_CFLAGS="$LIBIDL_CFLAGS"
+ HOST_LIBIDL_LIBS="$LIBIDL_LIBS"
+ fi
+Index: mozilla/configure
+===================================================================
+--- mozilla.orig/configure 2005-03-30 17:58:47.000000000 +0000
++++ mozilla/configure 2005-09-30 11:38:36.000000000 +0000
+@@ -16572,11 +16572,18 @@
+
+ if test -n "$CROSS_COMPILE"; then
+ if test -z "$HOST_LIBIDL_CONFIG"; then
++ echo "HOST_LIBIDL_CONFIG nto defined"
+ HOST_LIBIDL_CONFIG="$LIBIDL_CONFIG"
+ fi
+- if test -n "$HOST_LIBIDL_CONFIG"; then
++ if test -n "$HOST_LIBIDL_CONFIG" && test -n "$HOST_PKG_CONFIG_PATH"; then
++ echo "using $HOST_LIBIDL_CONFIG as HOST_LIBIDL_CONFIG with HOST_PKG_CONFIG_PATH=$HOST_PKG_CONFIG_PATH"
++ _SAVE_PKG_CONFIG_PATH=$PKG_CONFIG_PATH
++ PKG_CONFIG_PATH=$HOST_PKG_CONFIG_PATH
+ HOST_LIBIDL_CFLAGS=`${HOST_LIBIDL_CONFIG} --cflags`
++ echo "HOST_LIBIDL_CFLAGS = $HOST_LIBIDL_CFLAGS"
+ HOST_LIBIDL_LIBS=`${HOST_LIBIDL_CONFIG} --libs`
++ echo "HOST_LIBIDL_LIBS = $HOST_LIBIDL_LIBS"
++ PKG_CONFIG_PATH=$_SAVE_PKG_CONFIG_PATH
+ else
+ HOST_LIBIDL_CFLAGS="$LIBIDL_CFLAGS"
+ HOST_LIBIDL_LIBS="$LIBIDL_LIBS"
diff --git a/meta/packages/mozilla/minimo/mozconfig b/meta/packages/mozilla/minimo/mozconfig
new file mode 100644
index 0000000000..5a84bcf87e
--- /dev/null
+++ b/meta/packages/mozilla/minimo/mozconfig
@@ -0,0 +1,76 @@
+# build minimo
+MINIMO=1
+mk_add_options MINIMO=1
+
+# enable building the browser
+ac_add_options --enable-application=browser
+
+# use GTK+-2 widget set with XFT font rendering
+
+MOZ_ENABLE_COREXFONTS=0
+mk_add_options MOZ_ENABLE_COREXFONTS=0
+ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --enable-xft
+ac_add_options --disable-freetype2
+
+# disable XUL support to reduce codesize
+ac_add_options --disable-xul
+
+# enable minimal profile support
+ac_add_options --disable-profilesharing
+ac_add_options --disable-profilelocking
+ac_add_options --enable-single-profile
+
+# disable features and skip various build steps
+ac_add_options --disable-extensions
+ac_add_options --disable-accessibility
+ac_add_options --disable-composer
+ac_add_options --disable-extensions
+ac_add_options --disable-installer
+ac_add_options --disable-jsd
+ac_add_options --disable-jsloader
+ac_add_options --disable-ldap
+ac_add_options --disable-mailnews
+ac_add_options --disable-mathml
+ac_add_options --disable-necko-disk-cache
+ac_add_options --disable-postscript
+ac_add_options --disable-view-source
+ac_add_options --disable-xpfe-components
+ac_add_options --disable-xpinstall
+ac_add_options --disable-xprint
+ac_add_options --enable-native-uconv
+ac_add_options --enable-plaintext-editor-only
+ac_add_options --disable-v1-string-abi
+ac_add_options --disable-plugins
+
+# configure necko to allocate smaller network buffers
+ac_add_options --enable-necko-small-buffers
+
+# disable debug logging and tests
+ac_add_options --disable-dtd-debug
+ac_add_options --disable-logging
+ac_add_options --disable-tests
+
+# build crypto module (PSM + NSS)
+ac_add_options --enable-crypto
+
+# build minimal set of protocol handlers
+ac_add_options --enable-necko-protocols=http,file,res,jar
+
+# build minimal set of image decoders
+ac_add_options --enable-image-decoders=png,gif,jpeg
+
+# code generation options (optimize for size)
+ac_add_options --enable-optimize=-Os
+ac_add_options --enable-strip
+ac_add_options --disable-debug
+ac_add_options --enable-reorder
+ac_add_options --enable-elf-dynstr-gc
+
+# enable static build
+ac_add_options --disable-shared
+ac_add_options --enable-static
+
+# remove link dependency on libstdc++.so
+LIBS=-lsupc++
+