summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2017-04-24 15:43:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-04 13:49:46 +0100
commite1dd85c0fac171e2e99543705117acff9afd713b (patch)
treecebc55739e14a0e5b406c81f89863de05a4d8dbf
parent70b145715d335f5177b39dae398e789dc84f1fd3 (diff)
downloadopenembedded-core-e1dd85c0fac171e2e99543705117acff9afd713b.tar.gz
openembedded-core-e1dd85c0fac171e2e99543705117acff9afd713b.tar.bz2
openembedded-core-e1dd85c0fac171e2e99543705117acff9afd713b.zip
python3: add python3 metapackage
Many new users add "python3" to their image using IMAGE_INSTALL and are then surprised that they can't import any of the standard library. This is because we split up the standard library into a number of packages, and python3-core (the interpreter and essential modules only) RPROVIDES 'python3'. Solve this by moving the RPROVIDES of 'python3' to python3-modules, so that the entire Python standard library is installed. [ YOCTO #11182 ] Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.5.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.2.bb b/meta/recipes-devtools/python/python3_3.5.2.bb
index 2ff7c9e278..7f2bc7186f 100644
--- a/meta/recipes-devtools/python/python3_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3_3.5.2.bb
@@ -193,7 +193,7 @@ py_package_preprocess () {
require python-${PYTHON_MAJMIN}-manifest.inc
# manual dependency additions
-RPROVIDES_${PN}-core = "${PN}"
+RPROVIDES_${PN}-modules = "${PN}"
RRECOMMENDS_${PN}-core = "${PN}-readline"
RRECOMMENDS_${PN}-crypt = "openssl"
RRECOMMENDS_${PN}-crypt_class-nativesdk = "nativesdk-openssl"