summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2013-05-24 15:22:02 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-16 10:39:44 +0100
commitbd8df0e655dbe17f5cdd094a7386a6a1ab54a39e (patch)
treef8e81ea904bb1b5a27ce711e094475680fe90f6c
parent1737a4cfb735ce266f7bee577635e5c42da2396b (diff)
downloadopenembedded-core-bd8df0e655dbe17f5cdd094a7386a6a1ab54a39e.tar.gz
openembedded-core-bd8df0e655dbe17f5cdd094a7386a6a1ab54a39e.tar.bz2
openembedded-core-bd8df0e655dbe17f5cdd094a7386a6a1ab54a39e.zip
libarchive: Fix build dependencies
Move to using the PACKAGECONFIG mechanism to select configure options and dependencies. Without this the system will attempt to discover various dependencies, and usually does so incorrectly. We also ensure that the nativesdk version does not inherit any of the DISTRO_FEATURES. We shouldn't need acl or xattr support for nativesdk. (From OE-Core master rev: d9f9bfed56ef8562256fc01c3e42e15734230c3a) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/libarchive/libarchive_2.8.5.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_2.8.5.bb b/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
index 5cf13e6eb4..06989d3189 100644
--- a/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
+++ b/meta/recipes-extended/libarchive/libarchive_2.8.5.bb
@@ -5,7 +5,25 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=4255e2e6f0349a4ac8fbd68459296e46"
PR = "r0"
-DEPENDS = "libxml2"
+PACKAGECONFIG ?= "libxml2 zlib bz2"
+
+PACKAGECONFIG_class-target += "\
+ ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
+ ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
+"
+
+PACKAGECONFIG_class-nativesdk += "largefile"
+
+PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
+PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
+PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,bzip2,"
+PACKAGECONFIG[xz] = "--with-lzmadec --with-lzma,--without-lzmadec --without-lzma,xz,"
+PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
+PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
+PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
SRC_URI = "http://libarchive.googlecode.com/files/libarchive-${PV}.tar.gz \
file://0001-Patch-from-upstream-revision-1990.patch \