summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Dragomir <daniel.dragomir@windriver.com>2015-01-17 15:01:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-17 22:38:34 +0100
commitde2aa7a56790581406f219339c9022638cd47494 (patch)
tree2e8aa612953330c829d1cc2bfbee0174d6987b54
parent7c6d8054bb87e56180920d790efc25d42e25ab8c (diff)
downloadopenembedded-core-de2aa7a56790581406f219339c9022638cd47494.tar.gz
openembedded-core-de2aa7a56790581406f219339c9022638cd47494.tar.bz2
openembedded-core-de2aa7a56790581406f219339c9022638cd47494.zip
gcc-runtime: Remove libgfortran data from receipe
Remove libgfortran packages from PACKAGES list as long as libgfortran has separate receipe since commit 5bde5d9b39ea67f19a1a6aedd0c08c6cfedcbe5f gcc: Allow fortran to build successfully in 4.8 Otherwise, when fortran support will be enabled in the compiler, both lingfortran and gcc-runtime receipes will create the same files and will try to install them. This will cause errors: ERROR: The recipe libgfortran is trying to install files into a shared area when those files already exist. Those files and their manifest location are: ... Please verify which recipe should provide the above files. (From OE-Core rev: 872342fa3d08edede4a0105ac3ddb0f2ae3224b4) Signed-off-by: Daniel Dragomir <daniel.dragomir@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime.inc15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-runtime.inc b/meta/recipes-devtools/gcc/gcc-runtime.inc
index 167869e1f2..5c369f46c6 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-runtime.inc
@@ -76,9 +76,6 @@ PACKAGES = "\
libssp \
libssp-dev \
libssp-staticdev \
- libgfortran \
- libgfortran-dev \
- libgfortran-staticdev \
libmudflap \
libmudflap-dev \
libmudflap-staticdev \
@@ -131,18 +128,6 @@ FILES_libssp-dev = "\
"
FILES_libssp-staticdev = "${libdir}/libssp*.a"
-FILES_libgfortran = "${libdir}/libgfortran.so.*"
-FILES_libgfortran-dev = "\
- ${libdir}/libgfortran*.so \
- ${libdir}/libgfortran.spec \
- ${libdir}/libgfortran.la \
- ${libdir}/gcc/${TARGET_SYS}/${BINV}/libgfortranbegin.* \
- ${libdir}/gcc/${TARGET_SYS}/${BINV}/libcaf_single* \
-"
-FILES_libgfortran-staticdev = "${libdir}/libgfortran.a"
-
-INSANE_SKIP_${MLPREFIX}libgfortran-dev = "staticdev"
-
FILES_libquadmath = "${libdir}/libquadmath*.so.*"
FILES_libquadmath-dev = "\
${libdir}/gcc/${TARGET_SYS}/${BINV}/include/quadmath* \