summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2014-12-18 15:54:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-17 11:33:46 +0100
commitc8f9b5c9a8e5179c2013f25decd6a5483df9c716 (patch)
tree91819cab77a5c98e9e6c06d2407c74277937679a
parent816a62af5181e940f4b5e5f35f6775499fad94eb (diff)
downloadopenembedded-core-c8f9b5c9a8e5179c2013f25decd6a5483df9c716.tar.gz
openembedded-core-c8f9b5c9a8e5179c2013f25decd6a5483df9c716.tar.bz2
openembedded-core-c8f9b5c9a8e5179c2013f25decd6a5483df9c716.zip
powertop: Fix build for !uclibc
* EXTRA_LDFLAGS isn't defined for !uclibc and configure fails when it reads it unexpanded, see config.log snippet: configure:4177: checking whether the C compiler works configure:4199: i586-oe-linux-gcc -m32 -march=i586 --sysroot=/OE/sysroots/qemux86 -O2 -pipe -g -feliminate-unused-debug-types -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed ${EXTRA_LDFLAGS} conftest.c >&5 i586-oe-linux-gcc: error: ${EXTRA_LDFLAGS}: No such file or directory configure:4203: $? = 1 configure:4241: result: no Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.6.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.6.1.bb b/meta/recipes-kernel/powertop/powertop_2.6.1.bb
index 58216c2d15..ddb510254a 100644
--- a/meta/recipes-kernel/powertop/powertop_2.6.1.bb
+++ b/meta/recipes-kernel/powertop/powertop_2.6.1.bb
@@ -14,8 +14,9 @@ SRC_URI[sha256sum] = "034cde6d5bb433fe0d29251d5cde5d4c2948abf05fe29ef10966b65933
inherit autotools gettext pkgconfig
# we need to explicitly link with libintl in uClibc systems
-LDFLAGS += "${EXTRA_LDFLAGS}"
+EXTRA_LDFLAGS ?= ""
EXTRA_LDFLAGS_libc-uclibc = "-lintl"
+LDFLAGS += "${EXTRA_LDFLAGS}"
# we do not want libncursesw if we can
do_configure_prepend() {