From 8d0b0994a86b2800363b7d1ab4384bd87fb94f6a Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 20 Mar 2009 12:28:27 -0700
Subject: uclibc: Get uclibc working in thumb mode.

	* WARNING!! Do not use bintils 2.19 or 2.19.1
          when compiling in thumb mode. The veneer generation
          does not work as expected. Use binutils 2.18 or binutils_cvs

	* Move LEAD_SONAME into uclibc.inc

	* Use no optimizations while compiling ldso.c
	  to over come a gcc ICE

	* Use ARM mode resolver for thumb mode. The
	  resolver depends on ip register and if we
	  use thumb function for _dl_linux_resolve then
	  it adds a veneer which corrupts ip.
---
 recipes/uclibc/bfin-uclibc_svn.bb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

(limited to 'recipes/uclibc/bfin-uclibc_svn.bb')

diff --git a/recipes/uclibc/bfin-uclibc_svn.bb b/recipes/uclibc/bfin-uclibc_svn.bb
index 7ab3e8ae61..9b438a25dc 100644
--- a/recipes/uclibc/bfin-uclibc_svn.bb
+++ b/recipes/uclibc/bfin-uclibc_svn.bb
@@ -7,7 +7,7 @@
 # on whether the base patches apply to the selected (SRCDATE) svn release.
 #
 UCLIBC_BASE ?= "0.9.29"
-PR = "r4"
+PR = "r5"
 PV = "${UCLIBC_BASE}+svnr${SRCREV}"
 
 require uclibc.inc
@@ -30,5 +30,3 @@ FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-${UCLIBC_BASE}', '$
 
 S = "${WORKDIR}/uClibc"
 
-LEAD_SONAME = "libc.so"
-
-- 
cgit v1.2.3