From 980269b4e3b93236ddf64da3814c357bdf7d1305 Mon Sep 17 00:00:00 2001
From: Holger Hans Peter Freyther <zecke@selfish.org>
Date: Tue, 16 Mar 2010 18:09:04 +0800
Subject: proftpd: Upgrade to the latest version.

---
 recipes/proftpd/proftpd_1.3.2e.bb | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
 create mode 100644 recipes/proftpd/proftpd_1.3.2e.bb

(limited to 'recipes/proftpd/proftpd_1.3.2e.bb')

diff --git a/recipes/proftpd/proftpd_1.3.2e.bb b/recipes/proftpd/proftpd_1.3.2e.bb
new file mode 100644
index 0000000000..b6cec1b707
--- /dev/null
+++ b/recipes/proftpd/proftpd_1.3.2e.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Secure ftp daemon"
+SECTION = "console/network"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/ftp/distrib/source/${PN}-${PV}.tar.gz;name=src \
+	file://make.patch;patch=1 \
+	"
+SRC_URI[src.md5sum] = "4ecb82cb1050c0e897d5343f6d2cc1ed"
+SRC_URI[src.sha256sum] = "7c7f295944e8e7c85060829deeaed74f3f0b36c8f1d3936277d59bbea5d60093"
+
+
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes ac_cv_func_setgrent_void=yes"
+LDFLAGS += "-Llib"
+PARALLEL_MAKE = ""
+
+do_configure () {
+	 ./configure \
+		   --disable-auth-pam \
+                   --build=${BUILD_SYS} \
+                   --host=${HOST_SYS} \
+                   --target=${TARGET_SYS} \
+                   --prefix=/usr \
+		   --sysconfdir=/etc \
+		   --sharedstatedir=/com \
+		   --localstatedir=/var \
+                   ${EXTRA_OECONF} \
+                   $@;
+}
+
+do_install () {
+	oe_runmake DESTDIR=${D} install
+}
+
+pkg_postinst () {
+	# more chown's might be needed
+        chown root:root /usr/sbin/proftpd
+}
-- 
cgit v1.2.3