From e2a0d680182fdbc6cb56c8f77b9e85da82d63ede Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Sun, 6 Aug 2006 21:26:10 +0000
Subject: packages/quilt: Fix build of quilt 0.45     The aclocal.m4 is an
 automatically generated file, created by aclocal.m4.     The OpenEmbedded
 project automatially removes this automatically generated     file to
 regenerate it using aclocal.     Readd the content from aclocal.m4 as
 acinclude.m4 which will be seen by     the same set of programs...     Or as
 the automake website says:         "The contents of `acinclude.m4', if it
 exists, are also automatically included in `aclocal.m4'. This is useful for
 incorporating local macros into `configure'."

---
 packages/quilt/quilt-0.45/aclocal.patch | 71 +++++++++++++++++++++++++++++++++
 packages/quilt/quilt_0.45.bb            |  2 +
 2 files changed, 73 insertions(+)
 create mode 100644 packages/quilt/quilt-0.45/aclocal.patch

(limited to 'packages/quilt')

diff --git a/packages/quilt/quilt-0.45/aclocal.patch b/packages/quilt/quilt-0.45/aclocal.patch
new file mode 100644
index 0000000000..03d99ed785
--- /dev/null
+++ b/packages/quilt/quilt-0.45/aclocal.patch
@@ -0,0 +1,71 @@
+Add the aclocal.m4 as acinclude.m4
+
+Index: quilt-0.45/acinclude.m4
+===================================================================
+--- /dev/null	1970-01-01 00:00:00.000000000 +0000
++++ quilt-0.45/acinclude.m4	2006-08-06 23:18:56.000000000 +0200
+@@ -0,0 +1,64 @@
++dnl Allow configure to specify a specific binary
++dnl 1: Environment variable
++dnl 2: binary name
++dnl 3: optional list of alternative binary names
++dnl 4: optional list of additional search directories
++AC_DEFUN([QUILT_COMPAT_PROG_PATH],[
++  m4_define([internal_$2_cmd],[esyscmd(ls compat/$2.in 2>/dev/null)])
++
++  AC_ARG_WITH($2, AC_HELP_STRING(
++    [--with-$2], [name of the $2 executable to use]
++                 m4_if(internal_$2_cmd,[],[],[ (use --without-$2
++                          to use an internal mechanism)])),
++  [
++    if test x"$withval" = xnone; then
++      AC_MSG_ERROR([Invalid configure argument.  use --without-$2])
++    fi
++    if test x"$withval" != xno; then
++      AC_MSG_CHECKING(for $2)
++      $1="$withval"
++      if test -e "$$1"; then
++	if test ! -f "$$1" -a ! -h "$$1" || test ! -x "$$1"; then
++	  AC_MSG_ERROR([$$1 is not an executable file])
++	fi
++      fi
++      AC_MSG_RESULT([$$1])
++      if test ! -e "$$1"; then
++        AC_MSG_WARN([$$1 does not exist])
++      fi
++      COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++    fi
++  ],[
++    m4_if([$3],[],[
++      AC_PATH_PROG($1,$2,,$PATH:$4)
++    ],[
++      AC_PATH_PROGS($1,$3,,$PATH:$4)
++      if test -n "$$1" -a "`expr "$$1" : '.*/\([[^/]]*\)$'`" != "$2"; then
++	COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++      fi
++    ])
++    m4_if([$4],[],[],[
++      if test -n "$$1"; then
++	as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++        for dir in "$4"; do
++          if test "`dirname $$1`" = "$dir"; then
++            COMPAT_SYMLINKS="$COMPAT_SYMLINKS $2"
++	    break
++	  fi
++        done
++	IFS="$as_save_IFS"
++      fi
++    ])
++  ])
++  if test -z "$$1"; then
++    m4_if(internal_$2_cmd,[],[
++      AC_MSG_ERROR([Please specify the location of $2 with the option '--with-$2'])
++    ],[
++      AC_MSG_WARN([Using internal $2 mechanism.  Use option '--with-$2' to override])
++      COMPAT_PROGRAMS="$COMPAT_PROGRAMS $2"
++      $1=$2
++      INTERNAL_$1=1
++    ])
++  fi
++  AC_SUBST($1)
++])
diff --git a/packages/quilt/quilt_0.45.bb b/packages/quilt/quilt_0.45.bb
index 9a08b19abd..cf96cc9bc9 100644
--- a/packages/quilt/quilt_0.45.bb
+++ b/packages/quilt/quilt_0.45.bb
@@ -2,6 +2,8 @@ RDEPENDS_${PN} += "patch diffstat bzip2"
 
 require quilt_${PV}.inc
 
+SRC_URI += "file://aclocal.patch;patch=1"
+
 inherit autotools gettext
 
 require quilt-package.inc
-- 
cgit v1.2.3