From ee27ee9edbf4d28d4b895b6e16a8573de054dea1 Mon Sep 17 00:00:00 2001
From: Michael Lauer <mickey@vanille-media.de>
Date: Fri, 20 Oct 2006 12:14:06 +0000
Subject: qte/qtopia-core: factor out qte_arch function into qte-functions.inc,
 use this from qtopia-core to get QT_ARCH

---
 packages/qte/qte-common_2.3.10.inc | 12 +-----------
 packages/qte/qte-functions.inc     | 11 +++++++++++
 packages/qte/qtopia-core_4.2.0.bb  | 10 ++++------
 3 files changed, 16 insertions(+), 17 deletions(-)
 create mode 100644 packages/qte/qte-functions.inc

(limited to 'packages/qte')

diff --git a/packages/qte/qte-common_2.3.10.inc b/packages/qte/qte-common_2.3.10.inc
index 3ea3c0d02d..b8ed16c6a8 100644
--- a/packages/qte/qte-common_2.3.10.inc
+++ b/packages/qte/qte-common_2.3.10.inc
@@ -69,17 +69,7 @@ SRC_URI_append_h1910        = "file://ipaq-keyboard.patch;patch=1 file://ipaq_so
 S = "${WORKDIR}/qt-${PV}"
 export QTDIR = "${S}"
 
-def qte_arch(d):
-	import bb, re
-	arch = bb.data.getVar('TARGET_ARCH', d, 1)
-	if re.match("^i.86$", arch):
-		arch = "x86"
-	elif arch == "x86_64":
-		arch = "x86"
-	elif arch == "mipsel":
-		arch = "mips"
-	return arch
-
+require qte-functions.inc
 QTE_ARCH := "${@qte_arch(d)}"
 
 #
diff --git a/packages/qte/qte-functions.inc b/packages/qte/qte-functions.inc
new file mode 100644
index 0000000000..f0ffb0e612
--- /dev/null
+++ b/packages/qte/qte-functions.inc
@@ -0,0 +1,11 @@
+def qte_arch(d):
+        import bb, re
+        arch = bb.data.getVar('TARGET_ARCH', d, 1)
+        if re.match("^i.86$", arch):
+                arch = "x86"
+        elif arch == "x86_64":
+                arch = "x86"
+        elif arch == "mipsel":
+                arch = "mips"
+        return arch
+
diff --git a/packages/qte/qtopia-core_4.2.0.bb b/packages/qte/qtopia-core_4.2.0.bb
index 2f937c5d84..ecb5978fed 100644
--- a/packages/qte/qtopia-core_4.2.0.bb
+++ b/packages/qte/qtopia-core_4.2.0.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
 PRIORITY = "optional"
 HOMEPAGE = "http://www.trolltech.com"
 DEPENDS = "glib-2.0 dbus-glib tslib"
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
            file://linux-oe-qmake.conf"
@@ -55,11 +55,10 @@ export OE_QMAKE_LIBDIR_QT="${QTDIR}/lib"
 export OE_QMAKE_INCDIR_QTOPIA="${QTOPIADIR}/include"
 export OE_QMAKE_LIBDIR_QTOPIA="${QTOPIADIR}/lib"
 
+require qte-functions.inc
+QT_ARCH := "${@qte_arch(d)}"
 
-# FIXME
-# We should have architecture detection here and translate it to the correct
-# Qtopia -embedded switch
-QT_ARCH = "arm"
+# FIXME use info.bbclass once it has been commited
 QT_ENDIAN = "-little-endian"
 
 # We don't build the examples and demos atm. They're quite big and not used
@@ -70,7 +69,6 @@ QT_CONFIG_FLAGS = "-release \
 	-nomake demos -nomake examples -nomake tools \
 	-qt-mouse-tslib"
 
-
 # We might want to package all the libraries separately, so you can really
 # fine-tune what to install. This is e.g. done in qt4-x11-free_4.1.2.bb.
 # What should these packages be called? I'm tempted to call them the same
-- 
cgit v1.2.3