From aaad1c8c596a0568435bf72ebcbfc1a19f012112 Mon Sep 17 00:00:00 2001
From: Oyvind Repvik <nail@nslu2-linux.org>
Date: Thu, 7 Sep 2006 12:34:00 +0000
Subject: openntpd: Fix initscript and reformat .bb to match OE style
 guidelines

---
 packages/openntpd/files/init        |  2 +-
 packages/openntpd/openntpd_3.7p1.bb | 38 ++++++++++++++++++-------------------
 2 files changed, 19 insertions(+), 21 deletions(-)

(limited to 'packages/openntpd')

diff --git a/packages/openntpd/files/init b/packages/openntpd/files/init
index d35c65299d..745f1701aa 100644
--- a/packages/openntpd/files/init
+++ b/packages/openntpd/files/init
@@ -7,7 +7,7 @@
 
 ntpd=/usr/sbin/ntpd
 test -x "$ntpd" || exit 0
-[ ! -d /var/shared/empty ] && mkdir /var/shared/empty
+[ ! -d /var/shared/empty ] && mkdir -p /var/shared/empty
 
 case "$1" in
   start)
diff --git a/packages/openntpd/openntpd_3.7p1.bb b/packages/openntpd/openntpd_3.7p1.bb
index 6649361fd4..4001eb7dae 100644
--- a/packages/openntpd/openntpd_3.7p1.bb
+++ b/packages/openntpd/openntpd_3.7p1.bb
@@ -6,43 +6,41 @@ LICENSE = "BSD"
 SECTION = "console/network"
 MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
 DEPENDS = "timezones"
-PR="r12"
+PR="r13"
 
 SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/openntpd-${PV}.tar.gz \
-	   file://autofoo.patch;patch=1 \
-	   file://adjtimex-${PV}.patch;patch=1 \
-	   file://makefile-install.patch;patch=1 \
-	   file://init"
-S = "${WORKDIR}/openntpd-${PV}"
-
-INITSCRIPT_NAME = "openntpd"
-INITSCRIPT_PARAMS = "defaults"
+           file://autofoo.patch;patch=1 \
+           file://adjtimex-${PV}.patch;patch=1 \
+           file://makefile-install.patch;patch=1 \
+           file://init"
 
+S = "${WORKDIR}/openntpd-${PV}"
 
 inherit autotools update-rc.d
 
+INITSCRIPT_NAME = "openntpd"  
+INITSCRIPT_PARAMS = "defaults"
+
 EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
-		--sysconfdir=/etc  --with-privsep-path=/${localstatedir}/shared/empty \
-		--with-privsep-user=ntpd \
-		--with-builtin-arc4random \
-		--without-ssl-dir \
-		"
+                --sysconfdir=/etc  --with-privsep-path=/${localstatedir}/shared/empty \
+                --with-privsep-user=ntpd \
+                --with-builtin-arc4random \
+                --without-ssl-dir"
 
 do_install_prepend() {
         install -d ${D}${sysconfdir}/init.d
 }
 
 do_install_append() {
-	install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
+        install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
 }
 
 pkg_postrm () {
-	grep ntpd ${sysconfdir}/passwd && deluser ntpd 
+        grep ntpd ${sysconfdir}/passwd && deluser ntpd 
 }
 
 pkg_postinst () {
-	[ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
-	grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
-	chown root:root ${localstatedir}/shared/empty
+        [ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
+        grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
+        chown root:root ${localstatedir}/shared/empty
 }
-	
-- 
cgit v1.2.3