From 1bb521fd96e47c6437bda16cf922d897a171fc14 Mon Sep 17 00:00:00 2001
From: "nslu2-linux.adm@bkbits.net" <nslu2-linux.adm@bkbits.net>
Date: Thu, 20 Jan 2005 10:40:08 +0000
Subject: Merge bk://oe-devel.bkbits.net/openembedded into
 bkbits.net:/repos/n/nslu2-linux/openembedded

2005/01/20 04:02:25-05:00 handhelds.org!kergoth
automake 1.9.x build fixes: ice, libsm, libxcursor, libxfixes, libxft, libxss, xcomposite, xdamage, xpm, xt, xtst.

2005/01/20 04:00:34-05:00 handhelds.org!kergoth
Disable PARALLEL_MAKE in opie-tinykate.

2005/01/20 03:58:05-05:00 handhelds.org!kergoth
rosetta: inherit gettext and depend on virtual/libintl.

2005/01/20 03:57:40-05:00 handhelds.org!kergoth
A few STAGING_KERNEL_DIR and PACKAGE_ARCH fixes for multimachine builds.

2005/01/20 03:53:46-05:00 handhelds.org!kergoth
tosa.conf: don't bother installing the real modutils.. the busybox modutils is fine.

2005/01/20 03:52:08-05:00 handhelds.org!kergoth
wireless-tools: Apply patch to stop poking into the kernel headers where it shouldnt be, clean things up, use the local wireless.h instead of the kernel's, and split out into more granular ipks.

2005/01/20 03:49:43-05:00 handhelds.org!kergoth
Patch ipkg to fix a bug when built for relatively recent uclibc.

BKrev: 41ef8a88apPGTS6jqkoO28j6FLNtjg
---
 packages/lockstat/lockstat_1.4.10.bb | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

(limited to 'packages/lockstat')

diff --git a/packages/lockstat/lockstat_1.4.10.bb b/packages/lockstat/lockstat_1.4.10.bb
index e69de29bb2..054ef4ca6f 100644
--- a/packages/lockstat/lockstat_1.4.10.bb
+++ b/packages/lockstat/lockstat_1.4.10.bb
@@ -0,0 +1,26 @@
+SECTION = "console/utils"
+DESCRIPTION = "A tool for retrieving kernel spinlock metering information."
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "virtual/kernel"
+
+SRC_URI = "ftp://oss.sgi.com/projects/lockmeter/download/lockstat-${PV}.tar.gz"
+S = "${WORKDIR}/lockstat"
+
+export KERNEL_VERSION = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}
+export KERNEL_SOURCE = ${@base_read_file('${STAGING_KERNEL_DIR}/kernel-source')}
+CFLAGS += " -I${KERNEL_SOURCE}/include"
+
+python () {
+# NOTE: any target machines with kernels supporting spinlock metering should
+# check the MACHINE variable here to prevent the SkipPackage.
+	raise bb.parse.SkipPackage("The target machine's kernel does not appear able to use spinlock metering.")
+}
+
+do_compile () {
+	oe_runmake
+}
+
+do_install () {
+	install -d ${D}/${sbindir}
+	install -m 0755 lockstat ${D}/${sbindir}/
+}
-- 
cgit v1.2.3